summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-05-10 15:23:14 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-05-10 15:23:14 +0000
commit563136c5baed9e2c0566c5fef8e04131b1622c5d (patch)
tree200377702c2d9269bc99eb91da5239da689db24b /net-misc/aria2/aria2-1.3.3.ebuild
parentStable for HPPA (bug #268858). (diff)
downloadgentoo-2-563136c5baed9e2c0566c5fef8e04131b1622c5d.tar.gz
gentoo-2-563136c5baed9e2c0566c5fef8e04131b1622c5d.tar.bz2
gentoo-2-563136c5baed9e2c0566c5fef8e04131b1622c5d.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/aria2/aria2-1.3.3.ebuild')
-rw-r--r--net-misc/aria2/aria2-1.3.3.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-misc/aria2/aria2-1.3.3.ebuild b/net-misc/aria2/aria2-1.3.3.ebuild
new file mode 100644
index 000000000000..0e1f15b3bd3d
--- /dev/null
+++ b/net-misc/aria2/aria2-1.3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.3.3.ebuild,v 1.1 2009/05/10 15:23:14 dev-zero Exp $
+
+EAPI="2"
+
+DESCRIPTION="A download utility with resuming and segmented downloading with HTTP/HTTPS/FTP/BitTorrent support."
+HOMEPAGE="http://aria2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="ares bittorrent expat gnutls metalink nls sqlite ssl test"
+
+CDEPEND="sys-libs/zlib
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.9 )
+ !gnutls? ( dev-libs/openssl ) )
+ ares? ( >=net-dns/c-ares-1.5.0 )
+ bittorrent? (
+ gnutls? ( >=net-libs/gnutls-1.2.9 >=dev-libs/libgcrypt-1.2.2 )
+ !gnutls? ( dev-libs/openssl ) )
+ metalink? (
+ !expat? ( >=dev-libs/libxml2-2.6.26 )
+ expat? ( dev-libs/expat )
+ )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( >=dev-util/cppunit-1.12.0 )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libiconv virtual/libintl )"
+
+src_prepare() {
+ sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
+}
+
+src_configure() {
+ local myconf="--without-gnutls --without-openssl"
+ use ssl && \
+ myconf="$(use_with gnutls) $(use_with !gnutls openssl)"
+
+ # Note:
+ # - depends on libgcrypt only when using gnutls
+ # - links only against libxml2 and libexpat when metalink is enabled
+ # - always enable gzip/http compression since zlib should always be available anyway
+ # - always enable epoll since we can assume kernel 2.6.x
+ # - other options for threads: solaris, pth, win32
+ econf \
+ --enable-epoll \
+ --enable-threads=posix \
+ --with-libz \
+ $(use_enable nls) \
+ $(use_enable metalink) \
+ $(use_with expat libexpat) \
+ $(use_with !expat libxml2) \
+ $(use_with sqlite sqlite3) \
+ $(use_enable bittorrent) \
+ $(use_with ares libcares) \
+ ${myconf} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}/usr/share/doc/aria2c"
+ dodoc ChangeLog README AUTHORS NEWS
+ dohtml README.html doc/aria2c.1.html
+}