summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-08-29 19:06:08 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-08-29 19:06:08 +0000
commit5ede64531002f6e4ce0a69570ea782ca2e967aa7 (patch)
tree705db6495f09f4235a5cc480730ffdef49ab6c8c /net-misc/arpstar
parentRemoving kaiowas from metadata due to his retirement (see #61930 for reference). (diff)
downloadgentoo-2-5ede64531002f6e4ce0a69570ea782ca2e967aa7.tar.gz
gentoo-2-5ede64531002f6e4ce0a69570ea782ca2e967aa7.tar.bz2
gentoo-2-5ede64531002f6e4ce0a69570ea782ca2e967aa7.zip
Fix 2.6.22 kernel thanks to Jernej Kos <kostko@unimatrix-one.org> in bug 189718
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-misc/arpstar')
-rw-r--r--net-misc/arpstar/ChangeLog8
-rw-r--r--net-misc/arpstar/arpstar-0.5.5-r1.ebuild5
-rw-r--r--net-misc/arpstar/files/2.6.22.patch61
3 files changed, 71 insertions, 3 deletions
diff --git a/net-misc/arpstar/ChangeLog b/net-misc/arpstar/ChangeLog
index d49554bbb509..259ddf34f1d3 100644
--- a/net-misc/arpstar/ChangeLog
+++ b/net-misc/arpstar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/arpstar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arpstar/ChangeLog,v 1.9 2007/05/12 02:05:52 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arpstar/ChangeLog,v 1.10 2007/08/29 19:06:08 genstef Exp $
+
+*arpstar-0.5.5-r1.ebuild (29 Aug 2007)
+
+ 29 Aug 2007; Stefan Schweizer <genstef@gentoo.org> +files/2.6.22.patch,
+ arpstar-0.5.5-r1.ebuild:
+ Fix 2.6.22 kernel thanks to Jernej Kos <kostko@unimatrix-one.org> in bug 189718
12 May 2007; Daniel Drake <dsd@gentoo.org> metadata.xml:
Move from kernel to kernel-misc herd
diff --git a/net-misc/arpstar/arpstar-0.5.5-r1.ebuild b/net-misc/arpstar/arpstar-0.5.5-r1.ebuild
index cd4ae97334a4..2af967c0b9ea 100644
--- a/net-misc/arpstar/arpstar-0.5.5-r1.ebuild
+++ b/net-misc/arpstar/arpstar-0.5.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arpstar/arpstar-0.5.5-r1.ebuild,v 1.4 2007/02/25 09:21:37 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arpstar/arpstar-0.5.5-r1.ebuild,v 1.5 2007/08/29 19:06:08 genstef Exp $
inherit eutils linux-mod
@@ -25,7 +25,8 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${P}-2.6.16.patch || die "epatch failed"
+ epatch "${FILESDIR}"/${P}-2.6.16.patch
+ epatch "${FILESDIR}"/2.6.22.patch
}
src_install() {
diff --git a/net-misc/arpstar/files/2.6.22.patch b/net-misc/arpstar/files/2.6.22.patch
new file mode 100644
index 000000000000..4565e95a97aa
--- /dev/null
+++ b/net-misc/arpstar/files/2.6.22.patch
@@ -0,0 +1,61 @@
+--- arpstar.c.orig 2007-08-21 16:07:16.000000000 +0200
++++ arpstar.c 2007-08-21 16:10:06.000000000 +0200
+@@ -113,7 +113,7 @@
+ struct in_ifaddr * ifa;
+
+ dev=(*skb)->dev;
+- arp = (*skb)->nh.arph;
++ arp = arp_hdr(*skb);
+ arp_ptr= (unsigned char *)(arp+1);
+ sha = arp_ptr;
+ arp_ptr += dev->addr_len;
+@@ -132,7 +132,7 @@
+ goto out;
+ if(arpop==1) /*received ARP request*/
+ {
+- e2dst=(unsigned char *)(*skb)->mac.raw;
++ e2dst=skb_mac_header(*skb);
+ /*check if it's for us and send reply if it is*/
+ ifa=indev->ifa_list;
+ while(ifa!=NULL)
+@@ -239,7 +239,7 @@
+ unsigned int status=NF_DROP;
+
+ dev=(*skb)->dev;
+- arp = (*skb)->nh.arph;
++ arp = arp_hdr(*skb);
+ arp_ptr= (unsigned char *)(arp+1);
+ sha = arp_ptr;
+ arp_ptr += dev->addr_len;
+@@ -267,9 +267,9 @@
+ {
+ u8 prot=1;
+ u32 ip;
+- if((*skb)->h.ipiph->protocol==prot) /*looking for icmp*/
++ if(ip_hdr(*skb)->protocol==prot) /*looking for icmp*/
+ {
+- ip=(*skb)->h.ipiph->saddr;
++ ip=ip_hdr(*skb)->saddr;
+ if(!check_ip(&ip,WAICMP))
+ add_ip(&ip,WAICMP);
+ }
+@@ -527,7 +527,7 @@
+
+ if(skb->len>=42||skb->len==28) /*28 is for wireless drivers that cut off ethernet header even though it's still accessible*/
+ {
+- arp = skb->nh.arph;
++ arp = arp_hdr(skb);
+ arp_ptr= (unsigned char *)(arp+1);
+ arpsrc = arp_ptr;
+ arp_ptr += dev->addr_len;
+@@ -535,8 +535,8 @@
+ arp_ptr += 4;
+ arpdst = arp_ptr;
+ arp_ptr += dev->addr_len;
+- e2dst=(unsigned char *)skb->mac.raw;
+- e2src=(unsigned char *)skb->mac.raw+ADDRLEN;
++ e2dst=skb_mac_header(skb);
++ e2src=skb_mac_header(skb)+ADDRLEN;
+ ifa=indev->ifa_list;
+ while(ifa!=NULL)
+ {