summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-07 21:11:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-07 21:11:03 +0000
commit563cfc7fa2d2ac04c9d243877df163590d7576f8 (patch)
treee8e706264436dfa00449f9e39a365ba8d3d50969 /net-misc/atftp
parentFixed bug #76090 (aalib and libcaca hard links). (diff)
downloadgentoo-2-563cfc7fa2d2ac04c9d243877df163590d7576f8.tar.gz
gentoo-2-563cfc7fa2d2ac04c9d243877df163590d7576f8.tar.bz2
gentoo-2-563cfc7fa2d2ac04c9d243877df163590d7576f8.zip
Added patch to fix building #71090.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-misc/atftp')
-rw-r--r--net-misc/atftp/ChangeLog6
-rw-r--r--net-misc/atftp/atftp-0.7.ebuild31
-rw-r--r--net-misc/atftp/files/atftp-0.7-gcc.patch20
3 files changed, 40 insertions, 17 deletions
diff --git a/net-misc/atftp/ChangeLog b/net-misc/atftp/ChangeLog
index 2bbc207644d8..57aa708f7ccd 100644
--- a/net-misc/atftp/ChangeLog
+++ b/net-misc/atftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/atftp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/ChangeLog,v 1.16 2005/02/07 15:17:14 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/ChangeLog,v 1.17 2005/02/07 21:11:03 vapier Exp $
+
+ 07 Feb 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/atftp-0.7-gcc.patch, atftp-0.7.ebuild:
+ Added patch to fix building #71090.
07 Feb 2005; Jan Brinkmann <luckyduck@gentoo.org> atftp-0.6.2.ebuild:
added ~amd64 to 0.6.2, fixes #81083
diff --git a/net-misc/atftp/atftp-0.7.ebuild b/net-misc/atftp/atftp-0.7.ebuild
index df6b8d5547e6..baa176a59e24 100644
--- a/net-misc/atftp/atftp-0.7.ebuild
+++ b/net-misc/atftp/atftp-0.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.7.ebuild,v 1.9 2005/02/07 15:17:14 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.7.ebuild,v 1.10 2005/02/07 21:11:03 vapier Exp $
+
+inherit eutils
DESCRIPTION="Advanced TFTP implementation client/server"
HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
@@ -8,29 +10,26 @@ SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc arm ~amd64"
+KEYWORDS="~amd64 arm ~ppc ~sparc ~x86"
IUSE="tcpd"
DEPEND="tcpd? ( sys-apps/tcp-wrappers )
!virtual/tftp"
PROVIDE="virtual/tftp"
-src_compile () {
- econf `use_enable tcpd libwrap` || die "./configure failed"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc.patch
+}
- sed -i \
- -e "/^CFLAGS =/s:-g::" \
- -e "/^CFLAGS =/s:-O2::" \
- -e "/^CFLAGS =/s:$: ${CFLAGS}:" \
- Makefile
- emake || die
+src_compile() {
+ econf $(use_enable tcpd libwrap) || die "./configure failed"
+ emake CFLAGS="${CFLAGS} -D_REENTRANT" || die
}
src_install() {
- make install DESTDIR=${D} || die "Installation failed"
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/atftp.init atftp
- insinto /etc/conf.d
- newins ${FILESDIR}/atftp.confd atftp
+ make install DESTDIR="${D}" || die "Installation failed"
+ newinitd ${FILESDIR}/atftp.init atftp
+ newconfd ${FILESDIR}/atftp.confd atftp
}
diff --git a/net-misc/atftp/files/atftp-0.7-gcc.patch b/net-misc/atftp/files/atftp-0.7-gcc.patch
new file mode 100644
index 000000000000..374dbdb01c71
--- /dev/null
+++ b/net-misc/atftp/files/atftp-0.7-gcc.patch
@@ -0,0 +1,20 @@
+--- argz.h.orig 2005-02-07 16:04:41.000000000 -0500
++++ argz.h 2005-02-07 16:05:01.000000000 -0500
+@@ -180,7 +180,7 @@
+ #ifdef __USE_EXTERN_INLINES
+ extern inline char *
+ __argz_next (__const char *__argz, size_t __argz_len,
+- __const char *__entry) __THROW
++ __const char *__entry)
+ {
+ if (__entry)
+ {
+@@ -194,7 +194,7 @@
+ }
+ extern inline char *
+ argz_next (__const char *__argz, size_t __argz_len,
+- __const char *__entry) __THROW
++ __const char *__entry)
+ {
+ return __argz_next (__argz, __argz_len, __entry);
+ }