summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-09-15 10:42:23 +0000
committerMichał Górny <mgorny@gentoo.org>2011-09-15 10:42:23 +0000
commit5bb2adb1bac293ff1bd9a146a890f3f86dd4191c (patch)
tree65839297de553c8a116a91b7f3368b3a2a2027c7 /net-misc/autoupnp/autoupnp-0.4.6.ebuild
parentVersion bump, fixes security issue in mod_proxy_ajp #382971 and regression fo... (diff)
downloadgentoo-2-5bb2adb1bac293ff1bd9a146a890f3f86dd4191c.tar.gz
gentoo-2-5bb2adb1bac293ff1bd9a146a890f3f86dd4191c.tar.bz2
gentoo-2-5bb2adb1bac293ff1bd9a146a890f3f86dd4191c.zip
Version bump. The new version fixes pthread optionality and uses libtinynotify.
(Portage version: 2.2.0_alpha55_p39/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/autoupnp/autoupnp-0.4.6.ebuild')
-rw-r--r--net-misc/autoupnp/autoupnp-0.4.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/autoupnp/autoupnp-0.4.6.ebuild b/net-misc/autoupnp/autoupnp-0.4.6.ebuild
new file mode 100644
index 000000000000..806eae5bf182
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autoupnp/autoupnp-0.4.6.ebuild,v 1.1 2011/09/15 10:42:23 mgorny Exp $
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://github.com/mgorny/autoupnp/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc
+ libnotify? ( x11-libs/libtinynotify )"
+DEPEND="${RDEPEND}"
+
+DOCS=( NEWS README )
+
+src_configure() {
+ myeconfargs=(
+ $(use_with libnotify)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ remove_libtool_files all
+}