summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:44:30 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:44:30 +0000
commit3f8cd953fd590d27d7d8878f9051c1f14f7891e9 (patch)
tree93d0c9ba4f1eb7e665ecd218a67d34e15d9a2cca /net-misc/autoupnp
parentImport the live ebuild. (diff)
downloadgentoo-2-3f8cd953fd590d27d7d8878f9051c1f14f7891e9.tar.gz
gentoo-2-3f8cd953fd590d27d7d8878f9051c1f14f7891e9.tar.bz2
gentoo-2-3f8cd953fd590d27d7d8878f9051c1f14f7891e9.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'net-misc/autoupnp')
-rw-r--r--net-misc/autoupnp/ChangeLog7
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-misc/autoupnp/ChangeLog b/net-misc/autoupnp/ChangeLog
index 70d2bfae0625..03ff14606d93 100644
--- a/net-misc/autoupnp/ChangeLog
+++ b/net-misc/autoupnp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/autoupnp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/autoupnp/ChangeLog,v 1.4 2012/08/31 08:56:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autoupnp/ChangeLog,v 1.5 2012/12/15 12:44:30 mgorny Exp $
+
+*autoupnp-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +autoupnp-9999.ebuild:
+ Import the live ebuild.
31 Aug 2012; Michał Górny <mgorny@gentoo.org> autoupnp-0.4.6.ebuild,
metadata.xml:
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
new file mode 100644
index 000000000000..c266acffec24
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autoupnp/autoupnp-9999.ebuild,v 1.1 2012/12/15 12:44:30 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc
+ libnotify? ( x11-libs/libtinynotify )"
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ myeconfargs=(
+ $(use_with libnotify)
+ )
+
+ autotools-utils_src_configure
+}