summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-08-14 12:53:58 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-08-14 12:53:58 +0000
commit18f89f2593cc7ca0a4e0c72a1f68a5c1e28e7603 (patch)
treeeeebbc1ac47705e2286647cd6a2713cc6e3e34b8 /net-misc/bird
parentWhitespace (diff)
downloadgentoo-2-18f89f2593cc7ca0a4e0c72a1f68a5c1e28e7603.tar.gz
gentoo-2-18f89f2593cc7ca0a4e0c72a1f68a5c1e28e7603.tar.bz2
gentoo-2-18f89f2593cc7ca0a4e0c72a1f68a5c1e28e7603.zip
Version bump to 3.11 as requested by Moyaze Shivji in the LINX engineering team. Also added intermediate 3.10 version.
(Portage version: 2.1.13.6/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-misc/bird')
-rw-r--r--net-misc/bird/ChangeLog10
-rw-r--r--net-misc/bird/bird-1.3.10.ebuild62
-rw-r--r--net-misc/bird/bird-1.3.11.ebuild62
3 files changed, 133 insertions, 1 deletions
diff --git a/net-misc/bird/ChangeLog b/net-misc/bird/ChangeLog
index d4143a8e7c69..dd4b74205d5a 100644
--- a/net-misc/bird/ChangeLog
+++ b/net-misc/bird/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/bird
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.23 2013/01/15 13:39:01 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.24 2013/08/14 12:53:58 chainsaw Exp $
+
+*bird-1.3.11 (14 Aug 2013)
+*bird-1.3.10 (14 Aug 2013)
+
+ 14 Aug 2013; Tony Vroon <chainsaw@gentoo.org> +bird-1.3.10.ebuild,
+ +bird-1.3.11.ebuild:
+ Version bump to 3.11 as requested by Moyaze Shivji in the LINX engineering
+ team. Also added intermediate 3.10 version.
*bird-1.3.9 (15 Jan 2013)
diff --git a/net-misc/bird/bird-1.3.10.ebuild b/net-misc/bird/bird-1.3.10.ebuild
new file mode 100644
index 000000000000..c4be81bed619
--- /dev/null
+++ b/net-misc/bird/bird-1.3.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.3.10.ebuild,v 1.1 2013/08/14 12:53:58 chainsaw Exp $
+
+EAPI=4
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_prepare() {
+ mkdir ipv6
+ tar c --exclude ipv6 . | tar x -C ipv6
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --disable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+
+ if use ipv6; then
+ cd ipv6
+ econf \
+ --enable-client \
+ --enable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+ fi
+}
+
+src_compile() {
+ emake
+ if use ipv6; then
+ cd ipv6
+ emake
+ fi
+}
+
+src_install() {
+ if use ipv6; then
+ newbin ipv6/birdc birdc6
+ newsbin ipv6/bird bird6
+ newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
+ fi
+ dobin birdc
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
+ dodoc doc/bird.conf.example
+}
diff --git a/net-misc/bird/bird-1.3.11.ebuild b/net-misc/bird/bird-1.3.11.ebuild
new file mode 100644
index 000000000000..df84289946b3
--- /dev/null
+++ b/net-misc/bird/bird-1.3.11.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.3.11.ebuild,v 1.1 2013/08/14 12:53:58 chainsaw Exp $
+
+EAPI=4
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_prepare() {
+ mkdir ipv6
+ tar c --exclude ipv6 . | tar x -C ipv6
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --disable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+
+ if use ipv6; then
+ cd ipv6
+ econf \
+ --enable-client \
+ --enable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+ fi
+}
+
+src_compile() {
+ emake
+ if use ipv6; then
+ cd ipv6
+ emake
+ fi
+}
+
+src_install() {
+ if use ipv6; then
+ newbin ipv6/birdc birdc6
+ newsbin ipv6/bird bird6
+ newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
+ fi
+ dobin birdc
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
+ dodoc doc/bird.conf.example
+}