summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-06-21 13:15:07 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-06-21 13:15:07 +0000
commit7406da50f28a83053ee6324f05f38730e4a9e7d9 (patch)
tree52058a0175602d6d3b33dfe48edd8c1b6534821f /net-misc/cgminer
parentKeyworded on alpha, bug #485170 (diff)
downloadgentoo-2-7406da50f28a83053ee6324f05f38730e4a9e7d9.tar.gz
gentoo-2-7406da50f28a83053ee6324f05f38730e4a9e7d9.tar.bz2
gentoo-2-7406da50f28a83053ee6324f05f38730e4a9e7d9.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/cgminer')
-rw-r--r--net-misc/cgminer/ChangeLog8
-rw-r--r--net-misc/cgminer/cgminer-4.4.0.ebuild6
-rw-r--r--net-misc/cgminer/cgminer-4.4.1.ebuild88
3 files changed, 98 insertions, 4 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index 45b0206c1a47..634b081f3df1 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/cgminer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.75 2014/06/17 15:14:31 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.76 2014/06/21 13:15:07 blueness Exp $
+
+*cgminer-4.4.1 (21 Jun 2014)
+
+ 21 Jun 2014; Anthony G. Basile <blueness@gentoo.org> +cgminer-4.4.1.ebuild,
+ cgminer-4.4.0.ebuild:
+ Version bump
*cgminer-4.4.0 (17 Jun 2014)
diff --git a/net-misc/cgminer/cgminer-4.4.0.ebuild b/net-misc/cgminer/cgminer-4.4.0.ebuild
index 3ac5107efe77..6e225ab774fa 100644
--- a/net-misc/cgminer/cgminer-4.4.0.ebuild
+++ b/net-misc/cgminer/cgminer-4.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.4.0.ebuild,v 1.1 2014/06/17 15:14:31 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.4.0.ebuild,v 1.2 2014/06/21 13:15:07 blueness Exp $
EAPI=5
@@ -8,8 +8,8 @@ inherit autotools eutils flag-o-matic
DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
-SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
-#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.4/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/4.4/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
diff --git a/net-misc/cgminer/cgminer-4.4.1.ebuild b/net-misc/cgminer/cgminer-4.4.1.ebuild
new file mode 100644
index 000000000000..d8ebb37ed87e
--- /dev/null
+++ b/net-misc/cgminer/cgminer-4.4.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.4.1.ebuild,v 1.1 2014/06/21 13:15:07 blueness Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.4/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+HARDWARE="ants1 ants2 avalon avalon2 bab bitmine_A1 bflsc bitforce bitfury cointerra drillbit hashfast icarus klondike knc minion modminer spondoolies"
+IUSE="doc examples udev hardened ncurses ${HARDWARE}"
+
+REQUIRED_USE="|| ( ${HARDWARE} )"
+
+RDEPEND="net-misc/curl
+ >=dev-libs/jansson-2.5
+ ncurses? ( sys-libs/ncurses )
+ avalon? ( virtual/libusb:1 )
+ bflsc? ( virtual/libusb:1 )
+ bitforce? ( virtual/libusb:1 )
+ bitfury? ( virtual/libusb:1 )
+ cointerra? ( virtual/libusb:1 )
+ drillbit? ( virtual/libusb:1 )
+ hashfast? ( virtual/libusb:1 )
+ icarus? ( virtual/libusb:1 )
+ klondike? ( virtual/libusb:1 )
+ modminer? ( virtual/libusb:1 )
+ spondoolies? ( virtual/libusb:1 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.3.5-system-jansson.patch
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable ants1) \
+ $(use_enable ants2) \
+ $(use_enable avalon) \
+ $(use_enable avalon2) \
+ $(use_enable bab) \
+ $(use_enable bitmine_A1) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable drillbit) \
+ $(use_enable hashfast) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable knc) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable spondoolies) \
+ --with-system-libusb
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}