summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-11-26 01:44:00 +0000
committerWout Mertens <wmertens@gentoo.org>2003-11-26 01:44:00 +0000
commit318359b7f816e2836999149a4cf4a1106d93cc29 (patch)
tree1d2dea694fd6b059b3f5ee230cd009de224462a7 /net-misc/chrony
parentVersion bump (diff)
downloadgentoo-2-318359b7f816e2836999149a4cf4a1106d93cc29.tar.gz
gentoo-2-318359b7f816e2836999149a4cf4a1106d93cc29.tar.bz2
gentoo-2-318359b7f816e2836999149a4cf4a1106d93cc29.zip
Version bump
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/ChangeLog8
-rw-r--r--net-misc/chrony/Manifest8
-rw-r--r--net-misc/chrony/chrony-1.20.ebuild45
-rw-r--r--net-misc/chrony/files/chrony-1.20-chrony.conf.example-gentoo.diff46
-rw-r--r--net-misc/chrony/files/chrony-1.20-conf.c-gentoo.diff11
-rw-r--r--net-misc/chrony/files/chronyd.conf19
-rw-r--r--net-misc/chrony/files/chronyd.rc4
-rw-r--r--net-misc/chrony/files/digest-chrony-1.201
8 files changed, 134 insertions, 8 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index c0bce1712d8d..03dbf939f005 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-misc/chrony
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.10 2003/10/06 21:40:54 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.11 2003/11/26 01:43:55 wmertens Exp $
+*chrony-1.20 (26 Nov 2003)
+
+ 26 Nov 2003; Wout Mertens <wmertens@gentoo.org> :
+ version bump. Should fix #33934 and #21058.
+ Some better RTC configuration thanks to Rob Davies, #28040.
+
06 Oct 2003; Jason Wever <weeve@gentoo.org> chrony-1.19.99.2.ebuild,
chrony-1.19.ebuild:
Marked 1.19.99.2 to stable and masked 1.19 to fix bug #30499.
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index e8eb72d73a2e..7cd3b905ab2b 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -1,10 +1,10 @@
-MD5 47278c251554b39e15d3180ac25728c5 ChangeLog 1316
-MD5 c544bd104710689a4e10b073324a0831 chrony-1.20.ebuild 1188
+MD5 2d8b5320f467a89d9c2a4b08905325ec ChangeLog 1510
+MD5 242c100e3fd67f202d9b380f2d347503 chrony-1.20.ebuild 1186
MD5 ba43a52b9b5c1b07a57b1301a26fa544 chrony-1.19.ebuild 1183
MD5 c544bd104710689a4e10b073324a0831 chrony-1.19.99.2.ebuild 1188
-MD5 110ea7eae2031da898ff83f8ae47e22f files/chronyd.conf 258
+MD5 d06dfee7fc077a1c209193d1627efd96 files/chronyd.conf 795
MD5 b778857b5d802a10ec3e9ffd6ba9d226 files/chrony-1.19.99.2-conf.c-gentoo.diff 342
-MD5 e43a2a937eabda9d021429fe7f15ba22 files/chronyd.rc 1610
+MD5 a9b084f00b5e3860eeee3de4c0a8d14d files/chronyd.rc 1618
MD5 530b19caa6b14e1501530401f8cdc986 files/digest-chrony-1.20 63
MD5 c0e426c615798b7c75afc3b1aadcd727 files/digest-chrony-1.19 63
MD5 fa94342edcd12320e3fc947c7921c771 files/chrony-1.19-chrony.conf.example-gentoo.diff 1592
diff --git a/net-misc/chrony/chrony-1.20.ebuild b/net-misc/chrony/chrony-1.20.ebuild
new file mode 100644
index 000000000000..57340923ac26
--- /dev/null
+++ b/net-misc/chrony/chrony-1.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.20.ebuild,v 1.1 2003/11/26 01:43:56 wmertens Exp $
+
+inherit eutils
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.sunsite.dk/"
+SRC_URI="http://chrony.sunsite.dk/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 sparc"
+IUSE="readline"
+
+DEPEND="virtual/glibc
+ readline? ( >=readline-4.1-r4 )"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-conf.c-gentoo.diff
+ epatch ${FILESDIR}/${P}-chrony.conf.example-gentoo.diff
+}
+
+src_compile() {
+ econf `use_enable readline` || die
+ emake all docs || die
+}
+
+src_install() {
+ # the chrony install is brain-dead so we'll just do it ourselves
+ dobin chronyc
+ dosbin chronyd
+
+ dodoc chrony.txt README examples/chrony.{conf,keys}.example
+ dohtml chrony.html
+ doman *.{1,5,8}
+ doinfo chrony.info*
+
+ dodir /etc/chrony
+ exeinto /etc/init.d ; newexe ${FILESDIR}/chronyd.rc chronyd
+ insinto /etc/conf.d ; newins ${FILESDIR}/chronyd.conf chronyd
+ dosed "s:the documentation directory:/usr/share/doc/${PF}/:" /etc/init.d/chronyd
+}
diff --git a/net-misc/chrony/files/chrony-1.20-chrony.conf.example-gentoo.diff b/net-misc/chrony/files/chrony-1.20-chrony.conf.example-gentoo.diff
new file mode 100644
index 000000000000..7f1f2c9cccfc
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.20-chrony.conf.example-gentoo.diff
@@ -0,0 +1,46 @@
+--- examples/chrony.conf.example.orig 2003-06-16 11:59:01.000000000 -0400
++++ examples/chrony.conf.example 2003-06-16 12:00:13.000000000 -0400
+@@ -3,5 +3,5 @@
+ #
+ # This is an example chrony configuration file. You should copy it to
+-# /etc/chrony.conf after uncommenting and editing the options that you
++# /etc/chrony/chrony.conf after uncommenting and editing the options that you
+ # want to enable. I have not included the more obscure options. Refer
+ # to the documentation for these.
+@@ -91,5 +91,5 @@
+ # generally want this, so it is uncommented.
+
+-driftfile /etc/chrony.drift
++driftfile /etc/chrony/chrony.drift
+
+ # If you want to use the program called chronyc to configure aspects of
+@@ -100,5 +100,5 @@
+ # assumed by default.
+
+-keyfile /etc/chrony.keys
++keyfile /etc/chrony/chrony.keys
+
+ # Tell chronyd which numbered key in the file is used as the password
+@@ -158,6 +158,6 @@
+ ! log measurements statistics tracking
+
+-If you have real time clock support enabled (see below), you might want
+-this line instead:
++# If you have real time clock support enabled (see below), you might want
++# this line instead:
+
+ ! log measurements statistics tracking rtc
+@@ -269,5 +269,5 @@
+ # kernel. (Note, these options apply only to Linux.)
+
+-! rtcfile /etc/chrony.rtc
++! rtcfile /etc/chrony/chrony.rtc
+
+ # Your RTC can be set to keep Universal Coordinated Time (UTC) or local
+@@ -285,5 +285,5 @@
+ # using devfs), uncomment and edit the following line.
+
+-! rtcdevice /dev/misc/rtc
++rtcdevice /dev/misc/rtc
+
+ #######################################################################
diff --git a/net-misc/chrony/files/chrony-1.20-conf.c-gentoo.diff b/net-misc/chrony/files/chrony-1.20-conf.c-gentoo.diff
new file mode 100644
index 000000000000..fabc47097ff9
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.20-conf.c-gentoo.diff
@@ -0,0 +1,11 @@
+--- conf.c.orig Sun May 12 14:07:31 2002
++++ conf.c Sun May 12 14:07:52 2002
+@@ -45,7 +45,7 @@
+
+ /* ================================================== */
+
+-#define DEFAULT_CONF_FILE "/etc/chrony.conf"
++#define DEFAULT_CONF_FILE "/etc/chrony/chrony.conf"
+
+ /* ================================================== */
+ /* Forward prototypes */
diff --git a/net-misc/chrony/files/chronyd.conf b/net-misc/chrony/files/chronyd.conf
index 8a33f59366f2..59f2af36aec8 100644
--- a/net-misc/chrony/files/chronyd.conf
+++ b/net-misc/chrony/files/chronyd.conf
@@ -1,5 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/files/chronyd.conf,v 1.1 2003/06/16 16:08:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/files/chronyd.conf,v 1.2 2003/11/26 01:43:56 wmertens Exp $
CFGFILE=/etc/chrony/chrony.conf
+
+#
+# Configuration dependant options :
+# -s - Set system time from RTC if rtcfile directive present
+# -r - Reload sample histories if dumponexit directive present
+#
+# The combination of "-s -r" allows chronyd to perform long term averaging of
+# the gain or loss rate across system reboots and shutdowns.
+#
+ARGS=""
+#
+# devfs creates the device for RTC if it's compiled into kernel
+test -c /dev/rtc && {
+ grep -q '^rtcfile' $CFGFILE && ARGS="$ARGS -s"
+}
+grep -q '^dumponexit$' $CFGFILE && ARGS="$ARGS -r"
+
diff --git a/net-misc/chrony/files/chronyd.rc b/net-misc/chrony/files/chronyd.rc
index 07ec4c10c159..479f8bc67d27 100644
--- a/net-misc/chrony/files/chronyd.rc
+++ b/net-misc/chrony/files/chronyd.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/files/chronyd.rc,v 1.3 2003/06/16 16:08:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/files/chronyd.rc,v 1.4 2003/11/26 01:43:56 wmertens Exp $
depend() {
need net
@@ -41,7 +41,7 @@ start() {
start-stop-daemon --start --quiet \
--exec /usr/sbin/chronyd \
--pidfile $PIDFILE \
- -- -f $CFGFILE
+ -- -f $CFGFILE $ARGS
eend $? "Failed to start chronyd"
}
diff --git a/net-misc/chrony/files/digest-chrony-1.20 b/net-misc/chrony/files/digest-chrony-1.20
new file mode 100644
index 000000000000..52c899e5af73
--- /dev/null
+++ b/net-misc/chrony/files/digest-chrony-1.20
@@ -0,0 +1 @@
+MD5 d0f89e9e13fa47d04fd9f99e56c615c2 chrony-1.20.tar.gz 308253