summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-11-05 04:39:56 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-11-05 04:39:56 +0000
commit6d53350be8a816652aff7aa7e734a7530ace72d1 (patch)
tree41e2c4ed8a15acd6690605e6746608e96e8a42a6 /net-misc/curl
parentBug #268961: kpartx fails on extended partitions, referencing the wrong paren... (diff)
downloadgentoo-2-6d53350be8a816652aff7aa7e734a7530ace72d1.tar.gz
gentoo-2-6d53350be8a816652aff7aa7e734a7530ace72d1.tar.bz2
gentoo-2-6d53350be8a816652aff7aa7e734a7530ace72d1.zip
version bump as per bug #291469
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.19.7.ebuild99
-rw-r--r--net-misc/curl/files/curl-7.19.7-test241.patch20
-rw-r--r--net-misc/curl/metadata.xml2
4 files changed, 128 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index ddbe2e2de223..d4f1c8909824 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.150 2009/09/13 12:36:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.151 2009/11/05 04:39:55 dragonheart Exp $
+
+*curl-7.19.7 (05 Nov 2009)
+
+ 05 Nov 2009; Daniel Black <dragonheart@gentoo.org> +curl-7.19.7.ebuild,
+ +files/curl-7.19.7-test241.patch, metadata.xml:
+ version bump as per bug #291469 thanks Gabriel
13 Sep 2009; Brent Baude <ranger@gentoo.org> curl-7.19.6.ebuild:
Marking curl-7.19.6 ppc64 for bug 281515
diff --git a/net-misc/curl/curl-7.19.7.ebuild b/net-misc/curl/curl-7.19.7.ebuild
new file mode 100644
index 000000000000..dc5976635be9
--- /dev/null
+++ b/net-misc/curl/curl-7.19.7.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.19.7.ebuild,v 1.1 2009/11/05 04:39:55 dragonheart Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit multilib eutils
+
+#MY_P=${P/_pre/-}
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
+#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
+#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="openssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
+
+RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
+ nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
+ openssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/libidn )
+ ares? ( >=net-dns/c-ares-1.4.0 )
+ kerberos? ( virtual/krb5 )
+ libssh2? ( >=net-libs/libssh2-0.16 )"
+
+# fbopenssl (not in gentoo) --with-spnego
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
+ epatch "${FILESDIR}"/curl-7.19.7-test241.patch
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
+ $(use_with idn libidn)
+ $(use_with kerberos gssapi /usr)
+ $(use_with libssh2)
+ $(use_enable ipv6)
+ $(use_enable ares)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile
+ --enable-maintainer-mode
+ --disable-sspi
+ --without-krb4
+ --without-spnego"
+
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls --without-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use nss; then
+ myconf="${myconf} --without-ssl --without-gnutls --with-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use openssl; then
+ myconf="${myconf} --without-gnutls --without-nss --with-ssl"
+ myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
+ else
+ myconf="${myconf} --without-gnutls --without-nss --without-ssl"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installed failed for current version"
+ rm -rf "${D}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/curl-7.19.7-test241.patch b/net-misc/curl/files/curl-7.19.7-test241.patch
new file mode 100644
index 000000000000..7297c1b5b13e
--- /dev/null
+++ b/net-misc/curl/files/curl-7.19.7-test241.patch
@@ -0,0 +1,20 @@
+--- tests/data/test241.orig 2008-11-20 08:12:35.000000000 +1100
++++ tests/data/test241 2009-11-05 14:22:07.000000000 +1100
+@@ -33,7 +33,7 @@
+ HTTP-IPv6 GET (using ip6-localhost)
+ </name>
+ <command>
+--g "http://ip6-localhost:%HTTP6PORT/241"
++-g "http://::1:%HTTP6PORT/241"
+ </command>
+ <precheck>
+ ./server/resolve --ipv6 ip6-localhost
+@@ -48,7 +48,7 @@
+ </strip>
+ <protocol>
+ GET /241 HTTP/1.1
+-Host: ip6-localhost:%HTTP6PORT
++Host: ::1:%HTTP6PORT
+ Accept: */*
+
+ </protocol>
diff --git a/net-misc/curl/metadata.xml b/net-misc/curl/metadata.xml
index 92bead64c4cc..39e8fc8cd11b 100644
--- a/net-misc/curl/metadata.xml
+++ b/net-misc/curl/metadata.xml
@@ -8,6 +8,8 @@
<use>
<flag name="ares">Enabled c-ares dns support</flag>
<flag name="libssh2">Enabled SSH urls in curl using libssh2</flag>
+ <flag name="openssl">Use openssl as the crypto engine</flag>
+ <flag name="openssl">Use gnutls as the crypto engine</flag>
<flag name="nss">Use NSS as the crypto engine</flag>
</use>
</pkgmetadata>