summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 22:48:36 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 22:48:36 +0000
commit55e21e77ad88950c2dbbcfcbe8e189e553c31828 (patch)
tree5a7b1d957f000c4e2b09118c9d1fad80624086b5 /net-misc/dhcp
parent*** empty log message *** (diff)
downloadgentoo-2-55e21e77ad88950c2dbbcfcbe8e189e553c31828.tar.gz
gentoo-2-55e21e77ad88950c2dbbcfcbe8e189e553c31828.tar.bz2
gentoo-2-55e21e77ad88950c2dbbcfcbe8e189e553c31828.zip
*** empty log message ***
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/dhcp-3.0_beta0207.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/dhcp/dhcp-3.0_beta0207.ebuild b/net-misc/dhcp/dhcp-3.0_beta0207.ebuild
new file mode 100644
index 000000000000..0e5a396369c6
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0_beta0207.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_beta0207.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+P=dhcp-3.0b2pl7
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+
+ cd ${S}
+ echo "CC = gcc ${CFLAGS}" > site.conf
+ echo "ETC = /etc/dhcp" >> site.conf
+ try ./configure
+ try make
+}
+
+src_install () {
+
+ cd ${S}/work.linux-2.2/client
+ into /usr
+ dosbin dhclient
+ doman *.5 *.8
+
+ cd ../common
+ doman *.5
+
+ cd ../dhcpctl
+ dolib libdhcpctl.a
+ insinto /usr/include
+ doins dhcpctl.h
+
+ cd ../omapip
+ dolib libomapi.a
+ doman *.3
+
+ cd ../relay
+ dosbin dhcrelay
+ doman *.8
+
+ cd ../server
+ dosbin dhcpd
+ doman *.5 *.8
+
+ cd ${S}/client
+ insinto /etc/dhcp
+ doins dhclient.conf
+ donewins scripts/linux dhclient-script
+
+ cd ${S}/server
+ doins dhcpd.conf
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip
+ doins alloc.h buffer.h omapip.h
+ cd ${S}/includes/isc
+ insinto /usr/include/isc
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ docinto doc
+ dodoc doc/*
+}
+
+
+