summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-01-30 18:18:34 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-01-30 18:18:34 +0000
commite6a03d22d7b63438202b0f3453d3cc751e136b71 (patch)
tree7cbd8b58e2b4cebfa3c0909bfe793801b3264b74 /net-misc/dhcpcd
parentExpand PATCHES array correctly. (diff)
downloadgentoo-2-e6a03d22d7b63438202b0f3453d3cc751e136b71.tar.gz
gentoo-2-e6a03d22d7b63438202b0f3453d3cc751e136b71.tar.bz2
gentoo-2-e6a03d22d7b63438202b0f3453d3cc751e136b71.zip
Add embedded use flag for #535960
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/dhcpcd-6.7.1.ebuild5
-rw-r--r--net-misc/dhcpcd/dhcpcd-9999.ebuild5
-rw-r--r--net-misc/dhcpcd/metadata.xml7
3 files changed, 12 insertions, 5 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-6.7.1.ebuild b/net-misc/dhcpcd/dhcpcd-6.7.1.ebuild
index d3f45bc32786..6cbd3e3b2b2e 100644
--- a/net-misc/dhcpcd/dhcpcd-6.7.1.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-6.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-6.7.1.ebuild,v 1.1 2015/01/30 11:09:54 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-6.7.1.ebuild,v 1.2 2015/01/30 18:18:34 williamh Exp $
EAPI=5
@@ -21,7 +21,7 @@ DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
LICENSE="BSD-2"
SLOT="0"
-IUSE="elibc_glibc ipv6 kernel_linux +udev"
+IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
@@ -68,6 +68,7 @@ src_configure()
--dbdir="${EPREFIX}/var/lib/dhcpcd" \
--localstatedir="${EPREFIX}/var" \
${rundir} \
+ $(use_enable embedded) \
$(use_enable ipv6) \
${dev} \
CC="$(tc-getCC)" \
diff --git a/net-misc/dhcpcd/dhcpcd-9999.ebuild b/net-misc/dhcpcd/dhcpcd-9999.ebuild
index 0e4aef39cf4c..a181542ede08 100644
--- a/net-misc/dhcpcd/dhcpcd-9999.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.17 2014/09/20 16:44:51 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.18 2015/01/30 18:18:34 williamh Exp $
EAPI=5
@@ -21,7 +21,7 @@ DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
LICENSE="BSD-2"
SLOT="0"
-IUSE="elibc_glibc ipv6 kernel_linux +udev"
+IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
@@ -68,6 +68,7 @@ src_configure()
--dbdir="${EPREFIX}/var/lib/dhcpcd" \
--localstatedir="${EPREFIX}/var" \
${rundir} \
+ $(use_enable embedded) \
$(use_enable ipv6) \
${dev} \
CC="$(tc-getCC)" \
diff --git a/net-misc/dhcpcd/metadata.xml b/net-misc/dhcpcd/metadata.xml
index 7ab634751716..202e48827a19 100644
--- a/net-misc/dhcpcd/metadata.xml
+++ b/net-misc/dhcpcd/metadata.xml
@@ -8,5 +8,10 @@
</maintainer>
<upstream>
<remote-id type="cpe">cpe:/a:roy_marples:dhcpcd</remote-id>
- </upstream>
+</upstream>
+<use>
+ <flag name="embedded">
+ Embed the definitions of dhcp options in the dhcpcd executable
+ </flag>
+</use>
</pkgmetadata>