summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-10-17 12:14:44 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-10-17 12:14:44 +0000
commit234fd9692e8be98061fffb6d335e550b033b8a30 (patch)
tree3c0855396ea39e1957bcc5c057350cd2a2537fcf /net-misc/drivel/drivel-1.2.1.ebuild
parent* Added >=app-text/tetex-2.96. (diff)
downloadgentoo-2-234fd9692e8be98061fffb6d335e550b033b8a30.tar.gz
gentoo-2-234fd9692e8be98061fffb6d335e550b033b8a30.tar.bz2
gentoo-2-234fd9692e8be98061fffb6d335e550b033b8a30.zip
add missing deps like libxml and gtksourceview
Diffstat (limited to 'net-misc/drivel/drivel-1.2.1.ebuild')
-rw-r--r--net-misc/drivel/drivel-1.2.1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-misc/drivel/drivel-1.2.1.ebuild b/net-misc/drivel/drivel-1.2.1.ebuild
index 5d64699c341c..da7305c59a82 100644
--- a/net-misc/drivel/drivel-1.2.1.ebuild
+++ b/net-misc/drivel/drivel-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-1.2.1.ebuild,v 1.1 2004/10/16 20:17:49 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-1.2.1.ebuild,v 1.2 2004/10/17 12:14:44 liquidx Exp $
inherit gnome2
@@ -13,12 +13,17 @@ IUSE=""
SLOT="0"
KEYWORDS="~x86 ~ppc"
+# note: there's also an optional rhythmbox dependency
+
RDEPEND=">=dev-libs/glib-2.4
>=x11-libs/gtk+-2.4
>=gnome-base/gconf-2
>=gnome-base/gnome-vfs-2.6
>=gnome-base/libgnomeui-2.0.3
+ >=gnome-base/libbonobo-2
>=gnome-base/libglade-2
+ >=dev-libs/libxml2-2
+ >=x11-libs/gtksourceview-1
>=net-misc/curl-7.10"
DEPEND="${RDEPEND}
@@ -27,9 +32,11 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
+G2CONF="${G2CONF} --without-rhythmbox"
+
src_unpack() {
unpack ${A}
- sed -e 's/-DGTK_DISABLE_DEPRECATED//g' -i ${S}/src/Makefile.in
- sed -e 's/-DGNOME_DISABLE_DEPRECATED//g' -i ${S}/src/Makefile.in
+# sed -e 's/-DGTK_DISABLE_DEPRECATED//g' -i ${S}/src/Makefile.in
+# sed -e 's/-DGNOME_DISABLE_DEPRECATED//g' -i ${S}/src/Makefile.in
}