summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-02-23 07:54:34 +0000
committerAlex Alexander <wired@gentoo.org>2011-02-23 07:54:34 +0000
commit9ebda1c2ecba822aa622f1259ccef10d0344a44c (patch)
tree4064dd4331b7949462b6b9d0da71e245e9027c94 /net-misc/googlecl/googlecl-0.9.12-r1.ebuild
parent[bump] virtual/perl-Test-Harness-3.230 (diff)
downloadgentoo-2-9ebda1c2ecba822aa622f1259ccef10d0344a44c.tar.gz
gentoo-2-9ebda1c2ecba822aa622f1259ccef10d0344a44c.tar.bz2
gentoo-2-9ebda1c2ecba822aa622f1259ccef10d0344a44c.zip
fixed bug #355913 (date not showing in the calendar's 'when' field)
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/googlecl/googlecl-0.9.12-r1.ebuild')
-rw-r--r--net-misc/googlecl/googlecl-0.9.12-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/googlecl/googlecl-0.9.12-r1.ebuild b/net-misc/googlecl/googlecl-0.9.12-r1.ebuild
new file mode 100644
index 000000000000..09b624d28970
--- /dev/null
+++ b/net-misc/googlecl/googlecl-0.9.12-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/googlecl/googlecl-0.9.12-r1.ebuild,v 1.1 2011/02/23 07:54:33 wired Exp $
+
+EAPI=3
+PYTHON_DEPEND="2:2.5:2.7"
+
+inherit distutils eutils
+
+DESCRIPTION="Command line tools for the Google Data APIs"
+HOMEPAGE="http://code.google.com/p/googlecl/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-python/gdata
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # fix 'when' field not showing dates, bug #355913
+ epatch "${FILESDIR}"/"${P}"-calendar_dates.patch
+
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc changelog || die "dodoc failed"
+ doman man/*.1 || die "doman failed"
+}