summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-05 05:37:38 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-05 05:37:38 +0000
commitcae04dc31883c9ec85626b995331d26c37b22025 (patch)
treef6cee807f4c217003efef11910cbdb76cf116236 /net-misc/hotot
parentDrop USE=git from the default as the overall size of the git package is large... (diff)
downloadgentoo-2-cae04dc31883c9ec85626b995331d26c37b22025.tar.gz
gentoo-2-cae04dc31883c9ec85626b995331d26c37b22025.tar.bz2
gentoo-2-cae04dc31883c9ec85626b995331d26c37b22025.zip
Version bump
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/hotot')
-rw-r--r--net-misc/hotot/ChangeLog7
-rw-r--r--net-misc/hotot/hotot-0.9.8.7.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/net-misc/hotot/ChangeLog b/net-misc/hotot/ChangeLog
index d70ba8fd7738..1af540f43d77 100644
--- a/net-misc/hotot/ChangeLog
+++ b/net-misc/hotot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/hotot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.10 2012/05/22 08:08:40 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.11 2012/06/05 05:37:38 xmw Exp $
+
+*hotot-0.9.8.7 (05 Jun 2012)
+
+ 05 Jun 2012; Michael Weber <xmw@gentoo.org> +hotot-0.9.8.7.ebuild:
+ Version bump
*hotot-0.9.8.4 (22 May 2012)
diff --git a/net-misc/hotot/hotot-0.9.8.7.ebuild b/net-misc/hotot/hotot-0.9.8.7.ebuild
new file mode 100644
index 000000000000..c97109a435d3
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.8.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.7.ebuild,v 1.1 2012/06/05 05:37:38 xmw Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="gtk? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit cmake-utils python
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/shellex/Hotot/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chrome gtk kde qt4"
+
+RDEPEND="
+ gtk? ( dev-python/pywebkitgtk )
+ qt4? ( x11-libs/qt-webkit:4
+ kde? ( kde-base/kdelibs ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ if ! use chrome ; then
+ die "enable one use flag of chrome, gtk or qt4"
+ fi
+ fi
+ fi
+ python_pkg_setup
+}
+
+src_unpack() {
+ default
+ mv shellex-Hotot-* ${P} || die
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} \
+ $(cmake-utils_use_with chrome CHROME) \
+ $(cmake-utils_use_with gtk GTK) \
+ $(cmake-utils_use_with kde KDE) \
+ $(cmake-utils_use_with qt4 QT) \
+ -DPYTHON_EXECUTABLE=$(PYTHON -2 -a)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}