summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-26 17:14:30 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-26 17:14:30 +0000
commit8391db9ccd6b58828d3dfffe364893f6cdcadca5 (patch)
treee1d3b23f7f8b091ed38ec37cefe5d6d675d54e2e /net-misc/iputils
parentStable for HPPA (bug #452590). (diff)
downloadgentoo-2-8391db9ccd6b58828d3dfffe364893f6cdcadca5.tar.gz
gentoo-2-8391db9ccd6b58828d3dfffe364893f6cdcadca5.tar.bz2
gentoo-2-8391db9ccd6b58828d3dfffe364893f6cdcadca5.zip
Fix CC/CFLAGS handling #454136 by Alphat-PC.
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/ChangeLog6
-rw-r--r--net-misc/iputils/files/iputils-20121221-makefile.patch29
2 files changed, 28 insertions, 7 deletions
diff --git a/net-misc/iputils/ChangeLog b/net-misc/iputils/ChangeLog
index 42d592154945..f89a42cb702e 100644
--- a/net-misc/iputils/ChangeLog
+++ b/net-misc/iputils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/iputils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.107 2013/01/25 05:28:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.108 2013/01/26 17:14:30 vapier Exp $
+
+ 26 Jan 2013; Mike Frysinger <vapier@gentoo.org>
+ files/iputils-20121221-makefile.patch:
+ Fix CC/CFLAGS handling #454136 by Alphat-PC.
*iputils-20121221 (25 Jan 2013)
diff --git a/net-misc/iputils/files/iputils-20121221-makefile.patch b/net-misc/iputils/files/iputils-20121221-makefile.patch
index 3517194d539c..66424c85cf8e 100644
--- a/net-misc/iputils/files/iputils-20121221-makefile.patch
+++ b/net-misc/iputils/files/iputils-20121221-makefile.patch
@@ -1,4 +1,4 @@
-From 8ed9db9f7079d1b602356e86ea13a7cf51f045b7 Mon Sep 17 00:00:00 2001
+From c66609d2c830d6fe06f48f5d38c54eb5cc6f2975 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Thu, 24 Jan 2013 23:36:16 -0500
Subject: [PATCH [iputils]] fix handling of CFLAGS
@@ -8,14 +8,23 @@ up in the environment already.
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
- Makefile | 10 ++++------
- 1 file changed, 4 insertions(+), 6 deletions(-)
+ Makefile | 13 +++++--------
+ 1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/Makefile b/Makefile
-index 2c49940..dc317b1 100644
+index 2c49940..ecabac3 100644
--- a/Makefile
+++ b/Makefile
-@@ -48,11 +48,10 @@ ENABLE_RDISC_SERVER=no
+@@ -2,8 +2,6 @@
+ # Configuration
+ #
+
+-# CC
+-CC=gcc
+ # Path to parent kernel include files directory
+ LIBC_INCLUDE=/usr/include
+ # Libraries
+@@ -48,11 +46,10 @@ ENABLE_RDISC_SERVER=no
# -------------------------------------
# What a pity, all new gccs are buggy and -Werror does not work. Sigh.
@@ -31,7 +40,7 @@ index 2c49940..dc317b1 100644
LDLIB=
FUNC_LIB = $(if $(filter static,$(1)),$(LDFLAG_STATIC) $(2) $(LDFLAG_DYNAMIC),$(2))
-@@ -113,7 +112,6 @@ IPV4_TARGETS=tracepath ping clockdiff rdisc arping tftpd rarpd
+@@ -113,7 +110,6 @@ IPV4_TARGETS=tracepath ping clockdiff rdisc arping tftpd rarpd
IPV6_TARGETS=tracepath6 traceroute6 ping6
TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
@@ -39,6 +48,14 @@ index 2c49940..dc317b1 100644
LDLIBS=$(LDLIB) $(ADDLIB)
UNAME_N:=$(shell uname -n)
+@@ -132,6 +128,7 @@ all: $(TARGETS)
+ $(COMPILE.c) $< $(DEF_$(patsubst %.o,%,$@)) -S -o $@
+ %.o: %.c
+ $(COMPILE.c) $< $(DEF_$(patsubst %.o,%,$@)) -o $@
++LINK.o += $(CFLAGS)
+ $(TARGETS): %: %.o
+ $(LINK.o) $^ $(LIB_$@) $(LDLIBS) -o $@
+
--
1.8.0.2