summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-08-03 23:34:19 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-08-03 23:34:19 +0000
commit1ca53e1bfefa762c212456c2d116b64bc5286653 (patch)
tree8307d5b53e961edb23ac1d88242d524e24e60823 /net-misc/ipv6calc
parentAllow sys-libs/db:4.7. (diff)
downloadgentoo-2-1ca53e1bfefa762c212456c2d116b64bc5286653.tar.gz
gentoo-2-1ca53e1bfefa762c212456c2d116b64bc5286653.tar.bz2
gentoo-2-1ca53e1bfefa762c212456c2d116b64bc5286653.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/ipv6calc')
-rw-r--r--net-misc/ipv6calc/ChangeLog7
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.97.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/net-misc/ipv6calc/ChangeLog b/net-misc/ipv6calc/ChangeLog
index 11756a369fe1..8b673369c23a 100644
--- a/net-misc/ipv6calc/ChangeLog
+++ b/net-misc/ipv6calc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ipv6calc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.79 2014/06/02 00:08:10 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.80 2014/08/03 23:34:19 blueness Exp $
+
+*ipv6calc-0.97.4 (03 Aug 2014)
+
+ 03 Aug 2014; Anthony G. Basile <blueness@gentoo.org> +ipv6calc-0.97.4.ebuild:
+ Version bump
*ipv6calc-0.97.2-r1 (02 Jun 2014)
diff --git a/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild b/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild
new file mode 100644
index 000000000000..912556967011
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.97.4.ebuild,v 1.1 2014/08/03 23:34:19 blueness Exp $
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="geoip test"
+
+RDEPEND="
+ dev-libs/openssl
+ geoip? ( >=dev-libs/geoip-1.4.7 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Digest-SHA1 )
+"
+
+#dev-perl/URI is needed for web interface, that is not installed now
+
+src_configure() {
+ if use geoip; then
+ myconf=$(use_enable geoip)
+ myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ fi
+ econf \
+ --disable-bundled-getopt \
+ --disable-bundled-md5 \
+ --enable-shared \
+ --enable-dynamic-load \
+ --enable-db-ieee \
+ --enable-db-ipv4 \
+ --enable-db-ipv6 \
+ --disable-ip2location \
+ ${myconf}
+}
+
+src_compile() {
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}