summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-06-17 11:38:33 +0000
committerPeter Volkov <pva@gentoo.org>2009-06-17 11:38:33 +0000
commit4224b77dba9704ed34a0daa609d62e27c963e2f4 (patch)
treee7401a1b5639308c3435013d2279ae47f8b99697 /net-misc/ipv6calc
parentBump (diff)
downloadgentoo-2-4224b77dba9704ed34a0daa609d62e27c963e2f4.tar.gz
gentoo-2-4224b77dba9704ed34a0daa609d62e27c963e2f4.tar.bz2
gentoo-2-4224b77dba9704ed34a0daa609d62e27c963e2f4.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-misc/ipv6calc')
-rw-r--r--net-misc/ipv6calc/ChangeLog9
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.72.2.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/net-misc/ipv6calc/ChangeLog b/net-misc/ipv6calc/ChangeLog
index 26836e9815b1..84372a51d9ad 100644
--- a/net-misc/ipv6calc/ChangeLog
+++ b/net-misc/ipv6calc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ipv6calc
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.22 2009/01/12 16:41:06 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.23 2009/06/17 11:38:33 pva Exp $
+
+*ipv6calc-0.72.2 (17 Jun 2009)
+
+ 17 Jun 2009; Peter Volkov <pva@gentoo.org> +ipv6calc-0.72.2.ebuild:
+ Version bump.
*ipv6calc-0.72.1 (12 Jan 2009)
diff --git a/net-misc/ipv6calc/ipv6calc-0.72.2.ebuild b/net-misc/ipv6calc/ipv6calc-0.72.2.ebuild
new file mode 100644
index 000000000000..828cb32f102c
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.72.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.72.2.ebuild,v 1.1 2009/06/17 11:38:33 pva Exp $
+
+inherit fixheadtails
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+DEPEND="geoip? ( >=dev-libs/geoip-1.4.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ht_fix_file configure
+}
+
+src_compile() {
+ econf $(use_enable geoip)
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog CREDITS README TODO USAGE || die
+}