summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-29 19:12:03 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-29 19:12:03 +0000
commitdbdea63b0f75450a196269d53a67f622f75fa859 (patch)
tree2f2c7e274647e18e889428ee8a867a11b235b8ca /net-misc/jigdo/jigdo-0.7.3.ebuild
parentFix sandbox violation, bug#219602, thanks to Patrizio Bassi for reporting (diff)
downloadgentoo-2-dbdea63b0f75450a196269d53a67f622f75fa859.tar.gz
gentoo-2-dbdea63b0f75450a196269d53a67f622f75fa859.tar.bz2
gentoo-2-dbdea63b0f75450a196269d53a67f622f75fa859.zip
Change sys-libs/db depend wrt #218467. Fix building with GCC 4.3 wrt #218465. Thanks to Peter Alfredsen. Also use econf, and stop patching econf generated Makefile in src_compile.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'net-misc/jigdo/jigdo-0.7.3.ebuild')
-rw-r--r--net-misc/jigdo/jigdo-0.7.3.ebuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/net-misc/jigdo/jigdo-0.7.3.ebuild b/net-misc/jigdo/jigdo-0.7.3.ebuild
index 7ae74b9d1b1e..7b4a96cc4a43 100644
--- a/net-misc/jigdo/jigdo-0.7.3.ebuild
+++ b/net-misc/jigdo/jigdo-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3.ebuild,v 1.6 2008/01/25 21:15:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3.ebuild,v 1.7 2008/04/29 19:12:02 drac Exp $
inherit eutils
@@ -11,38 +11,32 @@ SRC_URI="http://atterer.net/jigdo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-
IUSE="gtk nls berkdb libwww"
-DEPEND="gtk? ( >=x11-libs/gtk+-2.0.6 )
- nls? ( sys-devel/gettext )
- berkdb? ( =sys-libs/db-3* )
+RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
+ berkdb? ( >=sys-libs/db-3.2 )
libwww? ( >=net-libs/libwww-5.3.2 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
src_compile() {
local myconf
- use nls || myconf="${myconf} --disable-nls"
use gtk && use libwww || myconf="${myconf} --without-gui"
use berkdb || myconf="${myconf} --without-libdb"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man ${myconf} \
- --datadir=/usr/share || die "./configure failed"
-
- # Patch the Makefile so that when jidgo is installed, jigdo-lite has
- # the correct path to the debian mirrors file.
- epatch "${FILESDIR}"/makefile.patch
-
- emake || die
+ econf $(use_enable nls) ${myconf}
+ emake || die "emake failed."
}
src_install() {
- einstall || die
- dodoc COPYING README THANKS VERSION changelog
- dodoc doc/*.txt
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc changelog README THANKS doc/{Hacking,README-bindist,TechDetails}.txt
dohtml doc/*.html
}