summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-08-27 11:18:55 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-08-27 11:18:55 +0000
commit9b52f3e46f7cd402c41377478ae44f90b5bc853b (patch)
tree88cdf3a618125e2b1d8c5a97fe8e44959ea9ae6f /net-misc/knock/knock-0.3.ebuild
parentFixing bug #57421, thanks to Stefan Sperling. Cleaning up older distcc-config... (diff)
downloadgentoo-2-9b52f3e46f7cd402c41377478ae44f90b5bc853b.tar.gz
gentoo-2-9b52f3e46f7cd402c41377478ae44f90b5bc853b.tar.bz2
gentoo-2-9b52f3e46f7cd402c41377478ae44f90b5bc853b.zip
Added patch to make use of non-blocking TCP connections. Thanks to Per Cederberg <per@percederberg.net> in bug #59315.
Diffstat (limited to 'net-misc/knock/knock-0.3.ebuild')
-rw-r--r--net-misc/knock/knock-0.3.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/net-misc/knock/knock-0.3.ebuild b/net-misc/knock/knock-0.3.ebuild
index bf57b7c7a252..f1805790b745 100644
--- a/net-misc/knock/knock-0.3.ebuild
+++ b/net-misc/knock/knock-0.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.3.ebuild,v 1.5 2004/07/18 17:30:21 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.3.ebuild,v 1.6 2004/08/27 11:18:55 pyrania Exp $
+
+inherit eutils
DESCRIPTION="A simple port-knocking daemon"
HOMEPAGE="http://www.zeroflux.org/knock/"
@@ -13,6 +15,16 @@ SLOT="0"
LICENSE="GPL-2"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-nonblock.patch
+}
+
+src_compile() {
+ econf || die "could not configure"
+ emake || die "emake failed"
+}
+
src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc README