summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2004-12-21 12:37:43 +0000
committerJoe McCann <joem@gentoo.org>2004-12-21 12:37:43 +0000
commit0ce58d215ffded51eea7a7a246a9a96eb25b1ed9 (patch)
tree12a4fa0256db939f45f782c9df6f1c3c89acaf3b /net-misc/logjam
parentkeywords ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-0ce58d215ffded51eea7a7a246a9a96eb25b1ed9.tar.gz
gentoo-2-0ce58d215ffded51eea7a7a246a9a96eb25b1ed9.tar.bz2
gentoo-2-0ce58d215ffded51eea7a7a246a9a96eb25b1ed9.zip
Adding patch to fix offline synchronization, closes bug 71252
Diffstat (limited to 'net-misc/logjam')
-rw-r--r--net-misc/logjam/ChangeLog8
-rw-r--r--net-misc/logjam/Manifest5
-rw-r--r--net-misc/logjam/files/digest-logjam-4.4.0-r11
-rw-r--r--net-misc/logjam/files/logjam-4.4.0-offline-sync.patch16
-rw-r--r--net-misc/logjam/logjam-4.4.0-r1.ebuild46
5 files changed, 74 insertions, 2 deletions
diff --git a/net-misc/logjam/ChangeLog b/net-misc/logjam/ChangeLog
index 347bc1dcdbf3..1dd6743a29d1 100644
--- a/net-misc/logjam/ChangeLog
+++ b/net-misc/logjam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/logjam
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/ChangeLog,v 1.22 2004/07/23 09:23:57 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/ChangeLog,v 1.23 2004/12/21 12:37:43 joem Exp $
+
+*logjam-4.4.0-r1 (21 Dec 2004)
+
+ 21 Dec 2004; Joe McCann <joem@gentoo.org>
+ +files/logjam-4.4.0-offline-sync.patch, +logjam-4.4.0-r1.ebuild:
+ Adding patch to fix offline synchronization, closes bug 71252
23 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> logjam-4.4.0.ebuild:
Added to stable amd64
diff --git a/net-misc/logjam/Manifest b/net-misc/logjam/Manifest
index 25b453ea2bb8..488f4206bb0d 100644
--- a/net-misc/logjam/Manifest
+++ b/net-misc/logjam/Manifest
@@ -1,9 +1,12 @@
MD5 7e81bc076e9e28ba94119b5be324aa38 ChangeLog 2550
MD5 8483624e97d1d8c6cae5b9cdd161fcf0 logjam-4.2.2.ebuild 881
-MD5 374fe268b83f6463127d1b329b664ae1 logjam-4.3.2.ebuild 890
MD5 72ae04aadae3a76986773714e8939870 logjam-4.4.0.ebuild 1051
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 e9b81208a1ce533b704eba1396b260a8 logjam-4.4.0-r1.ebuild 998
+MD5 374fe268b83f6463127d1b329b664ae1 logjam-4.3.2.ebuild 890
MD5 2903f2d3b78e59f9ed8b9f012c5e2210 files/digest-logjam-4.2.2 64
MD5 94348f82d3a7b91d9988d1629c4bf2a8 files/digest-logjam-4.3.2 65
MD5 30945ddb58c8f3eb3780fcf9e48dbda3 files/digest-logjam-4.4.0 65
MD5 68dac613ab0e68a698fcac1864aeae45 files/logjam-4.4.0-gcc3.4.patch 241
+MD5 403b471dc638f3acfdb9ba6f5c69d440 files/logjam-4.4.0-offline-sync.patch 886
+MD5 30945ddb58c8f3eb3780fcf9e48dbda3 files/digest-logjam-4.4.0-r1 65
diff --git a/net-misc/logjam/files/digest-logjam-4.4.0-r1 b/net-misc/logjam/files/digest-logjam-4.4.0-r1
new file mode 100644
index 000000000000..cb53d3285ca6
--- /dev/null
+++ b/net-misc/logjam/files/digest-logjam-4.4.0-r1
@@ -0,0 +1 @@
+MD5 7ff366dee32d354338132bfd5c5adb46 logjam-4.4.0.tar.bz2 604310
diff --git a/net-misc/logjam/files/logjam-4.4.0-offline-sync.patch b/net-misc/logjam/files/logjam-4.4.0-offline-sync.patch
new file mode 100644
index 000000000000..0961c65806c9
--- /dev/null
+++ b/net-misc/logjam/files/logjam-4.4.0-offline-sync.patch
@@ -0,0 +1,16 @@
+--- orig/protocol/liblivejournal/livejournal/sync.c
++++ mod/protocol/liblivejournal/livejournal/sync.c
+@@ -33,8 +33,10 @@
+ static int
+ entry_date_compare_func(const void *a, const void *b) {
+ /* struct tm* cast needed to un-constify the times passed to mktime. */
+- const LJEntry *entrya = a; time_t timea = mktime((struct tm*)&entrya->time);
+- const LJEntry *entryb = b; time_t timeb = mktime((struct tm*)&entryb->time);
++ const LJEntry *entrya = *(LJEntry **)a;
++ const LJEntry *entryb = *(LJEntry **)b;
++ time_t timea = mktime((struct tm*)&entrya->time);
++ time_t timeb = mktime((struct tm*)&entryb->time);
+ /* mktime actually converts the times to local time, which isn't
+ * quite correct, but since we're comparing times directly like this
+ * it should still sort the same way and timegm is potentially slower. */
+
diff --git a/net-misc/logjam/logjam-4.4.0-r1.ebuild b/net-misc/logjam/logjam-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..8b96e05345f6
--- /dev/null
+++ b/net-misc/logjam/logjam-4.4.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-4.4.0-r1.ebuild,v 1.1 2004/12/21 12:37:43 joem Exp $
+
+IUSE="xmms spell gtkhtml"
+
+inherit eutils
+
+DESCRIPTION="GTK2-based LiveJournal client"
+HOMEPAGE="http://logjam.danga.com/"
+SRC_URI="http://logjam.danga.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND=">=x11-libs/gtk+-2
+ >=dev-libs/libxml2-2.0
+ net-misc/curl
+ gtkhtml? ( >=gnome-extra/libgtkhtml-3.0 )
+ spell? ( app-text/gtkspell )
+ xmms? ( media-sound/xmms )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc3.4.patch
+ epatch ${FILESDIR}/${P}-offline-sync.patch
+
+ sed -i -e s/logjam.png/logjam_pencil.png/ ${S}/data/logjam.desktop.in
+
+}
+
+src_compile() {
+
+ econf \
+ `use_enable xmms` \
+ `use_with gtkhtml` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc doc/README doc/TODO
+}