summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-08-30 09:57:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-08-30 09:57:25 +0000
commit2c412494ec991bf12a7ef6d9c3d254a0c71d7296 (patch)
tree88d62a413e4f8dc8e7682372e2211e7563555a77 /net-misc/logmein-hamachi
parentRemove die statements, they are redundant since EAPI 4. (diff)
downloadgentoo-2-2c412494ec991bf12a7ef6d9c3d254a0c71d7296.tar.gz
gentoo-2-2c412494ec991bf12a7ef6d9c3d254a0c71d7296.tar.bz2
gentoo-2-2c412494ec991bf12a7ef6d9c3d254a0c71d7296.zip
Version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-misc/logmein-hamachi')
-rw-r--r--net-misc/logmein-hamachi/ChangeLog10
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.1.0.130.ebuild65
2 files changed, 73 insertions, 2 deletions
diff --git a/net-misc/logmein-hamachi/ChangeLog b/net-misc/logmein-hamachi/ChangeLog
index ca30e0282044..382a0d0f0fe6 100644
--- a/net-misc/logmein-hamachi/ChangeLog
+++ b/net-misc/logmein-hamachi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/logmein-hamachi
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.14 2013/10/12 11:44:39 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.15 2014/08/30 09:57:25 hwoarang Exp $
+
+*logmein-hamachi-2.1.0.130 (30 Aug 2014)
+
+ 30 Aug 2014; Markos Chandras <hwoarang@gentoo.org>
+ +logmein-hamachi-2.1.0.130.ebuild:
+ Version bump
*logmein-hamachi-2.1.0.119 (12 Oct 2013)
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.130.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.130.ebuild
new file mode 100644
index 000000000000..da9f9a40599b
--- /dev/null
+++ b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.130.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.130.ebuild,v 1.1 2014/08/30 09:57:25 hwoarang Exp $
+
+EAPI=5
+inherit eutils linux-info systemd
+
+DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
+HOMEPAGE="https://secure.logmein.com/products/hamachi2"
+SRC_URI="x86? ( https://secure.logmein.com/labs/${P}-x86.tgz )
+ amd64? ( https://secure.logmein.com/labs/${P}-x64.tgz )"
+
+LICENSE="LogMeIn"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-misc/hamachi"
+
+RESTRICT="mirror"
+
+QA_PREBUILT="/opt/${PN}/bin/hamachid"
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
+QA_WX_LOAD="/opt/${PN}/bin/hamachid"
+
+pkg_setup() {
+ einfo "Checking your kernel configuration for TUN/TAP support."
+ CONFIG_CHECK="~TUN"
+ check_extra_config
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${P}-$(use x86 && echo x86 || echo x64)" "${S}" || die
+}
+
+src_install() {
+ into /opt/${PN}
+ dobin hamachid dnsup dnsdown
+ dosym /opt/${PN}/bin/hamachid /usr/bin/hamachi
+
+ # Config and log directory
+ dodir /var/lib/${PN}
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodoc CHANGES README
+}
+
+pkg_postinst() {
+ elog "LogMeIn Hamachi2 is installed."
+ elog "Consult the README file on how to configure your client."
+ elog "You can run the client 'hamachi' as root,"
+ elog "or as a user if you add a newline terminated line:"
+ elog "Ipc.User <login name>"
+ elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
+ elog "and restart the daemon with"
+ elog "/etc/init.d/${PN} restart"
+ elog "or:"
+ elog "systemctl restart ${PN}"
+ elog "To enable auto-login when the service starts set a nickname in"
+ elog "/etc/conf.d/${PN} (only supported using openRC)"
+}