summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2005-02-06 18:22:01 +0000
committerSimone Gotti <motaboy@gentoo.org>2005-02-06 18:22:01 +0000
commit0a5d98e7852f738c41976f296fc57534d951f799 (patch)
tree175454d8aefb1151ee1c9ae40efb8bdf1eda98a8 /net-misc/mDNSResponder/files
parentStable on ppc64 (diff)
downloadgentoo-2-0a5d98e7852f738c41976f296fc57534d951f799.tar.gz
gentoo-2-0a5d98e7852f738c41976f296fc57534d951f799.tar.bz2
gentoo-2-0a5d98e7852f738c41976f296fc57534d951f799.zip
Initial ebuild. mDNSResponder from Apple, needed by various programs like kdelibs-3.4. Closes bug #75046.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-misc/mDNSResponder/files')
-rw-r--r--net-misc/mDNSResponder/files/digest-mDNSResponder-981
-rw-r--r--net-misc/mDNSResponder/files/mDNSResponder-98-Makefiles.patch96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/mDNSResponder/files/digest-mDNSResponder-98 b/net-misc/mDNSResponder/files/digest-mDNSResponder-98
new file mode 100644
index 000000000000..34ba3f135c7e
--- /dev/null
+++ b/net-misc/mDNSResponder/files/digest-mDNSResponder-98
@@ -0,0 +1 @@
+MD5 26ddb6f2ed2c451704d26e80da5fdcb9 mDNSResponder-98.tar.gz 1369226
diff --git a/net-misc/mDNSResponder/files/mDNSResponder-98-Makefiles.patch b/net-misc/mDNSResponder/files/mDNSResponder-98-Makefiles.patch
new file mode 100644
index 000000000000..eb55c145f041
--- /dev/null
+++ b/net-misc/mDNSResponder/files/mDNSResponder-98-Makefiles.patch
@@ -0,0 +1,96 @@
+--- mDNSResponder-98/mDNSPosix/Makefile.orig 2005-01-27 22:55:00.000000000 +0000
++++ mDNSResponder-98/mDNSPosix/Makefile 2005-02-06 18:13:21.437292552 +0000
+@@ -369,7 +369,7 @@
+
+ all: setup Daemon libdns_sd Client Responder ProxyResponder Identify NetMonitor dnsextd $(OPTIONALTARG)
+
+-install: setup InstalledDaemon InstalledLib InstalledStartup InstalledManPages $(OPTINSTALL)
++install: setup InstalledDaemon InstalledLib InstalledManPages $(OPTINSTALL)
+
+ # 'setup' sets up the build directory structure the way we want
+ setup:
+@@ -418,36 +418,32 @@
+ #############################################################################
+
+ # The Install targets place built stuff in their proper places
+-InstalledDaemon: $(INSTBASE)/sbin/mdnsd
++InstalledDaemon: ${DESTDIR}/$(INSTBASE)/sbin/mdnsd
+ @echo $+ " installed"
+
+-InstalledLib: $(INSTBASE)/lib/libdns_sd.$(LDSUFFIX).$(LIBVERS) $(INSTBASE)/include/dns_sd.h
++InstalledLib: ${DESTDIR}/$(INSTBASE)/lib/libdns_sd.$(LDSUFFIX).$(LIBVERS) ${DESTDIR}/$(INSTBASE)/include/dns_sd.h
+ @echo $+ " installed"
+
+-InstalledStartup: $(STARTUPSCRIPTDIR)/$(STARTUPSCRIPTNAME)
++InstalledStartup: ${DESTDIR}/$(STARTUPSCRIPTDIR)/$(STARTUPSCRIPTNAME)
+ @echo $+ " installed"
+
+-InstalledNSS: $(NSSINSTPATH)/$(NSSLINKNAME) /etc/nss_mdns.conf $(MANPATH)/man5/nss_mdns.conf.5 $(MANPATH)/man8/libnss_mdns.8
++InstalledNSS: ${DESTDIR}/$(NSSINSTPATH)/$(NSSLINKNAME) ${DESTDIR}/etc/nss_mdns.conf ${DESTDIR}/$(MANPATH)/man5/nss_mdns.conf.5 ${DESTDIR}/$(MANPATH)/man8/libnss_mdns.8
+ @echo $+ " installed"
+
+-InstalledManPages: $(MANPATH)/man8/mdnsd.8
++InstalledManPages: ${DESTDIR}/$(MANPATH)/man8/mdnsd.8
+ @echo $+ " installed"
+
+-$(INSTBASE)/sbin/mdnsd: $(BUILDDIR)/mdnsd
++${DESTDIR}/$(INSTBASE)/sbin/mdnsd: $(BUILDDIR)/mdnsd
+ $(CP) $< $@
+
+-$(INSTBASE)/lib/libdns_sd.$(LDSUFFIX).$(LIBVERS): $(BUILDDIR)/libdns_sd.$(LDSUFFIX)
++${DESTDIR}/$(INSTBASE)/lib/libdns_sd.$(LDSUFFIX).$(LIBVERS): $(BUILDDIR)/libdns_sd.$(LDSUFFIX)
+ $(CP) $< $@
+- $(LN) $@ $(INSTBASE)/lib/libdns_sd.$(LDSUFFIX)
+-ifdef LDCONFIG
+- # -m means 'merge into existing database', -R means 'rescan directories'
+- $(LDCONFIG) -mR
+-endif
++ $(LN) $@ ${DESTDIR}/$(INSTBASE)/lib/libdns_sd.$(LDSUFFIX)
+
+-$(INSTBASE)/include/dns_sd.h: $(SHAREDDIR)/dns_sd.h
++${DESTDIR}/$(INSTBASE)/include/dns_sd.h: $(SHAREDDIR)/dns_sd.h
+ $(CP) $< $@
+
+-$(STARTUPSCRIPTDIR)/$(STARTUPSCRIPTNAME): mdnsd.sh $(STARTUPSCRIPTDIR)
++${DESTDIR}/$(STARTUPSCRIPTDIR)/$(STARTUPSCRIPTNAME): mdnsd.sh $(STARTUPSCRIPTDIR)
+ $(CP) $< $@
+ chmod ugo+x $@
+ ifdef RUNLEVELSCRIPTSDIR
+@@ -463,31 +459,26 @@
+ endif
+ endif
+
+-$(NSSINSTPATH)/$(NSSLINKNAME): $(NSSINSTPATH)/$(NSSLIBFILE)
++${DESTDIR}/$(NSSINSTPATH)/$(NSSLINKNAME): ${DESTDIR}/$(NSSINSTPATH)/$(NSSLIBFILE)
+ $(LN) $< $@
+- ldconfig
+
+-$(NSSINSTPATH)/$(NSSLIBFILE): $(BUILDDIR)/$(NSSLIBFILE)
++${DESTDIR}/$(NSSINSTPATH)/$(NSSLIBFILE): $(BUILDDIR)/$(NSSLIBFILE)
+ $(CP) $< $@
+ chmod 444 $@
+
+-/etc/nss_mdns.conf: nss_mdns.conf
++${DESTDIR}/etc/nss_mdns.conf: nss_mdns.conf
+ $(CP) $< $@
+ chmod 444 $@
+- # Check the nsswitch.conf file.
+- # If 'mdns' does not already appear on the "hosts:" line, then add it right before 'dns'
+- cp -f /etc/nsswitch.conf /etc/nsswitch.conf.pre-mdns
+- sed -e '/mdns/!s/^\(hosts:.*\)dns\(.*\)/\1mdns dns\2/' /etc/nsswitch.conf.pre-mdns > /etc/nsswitch.conf
+
+-$(MANPATH)/man5/%.5: %.5
++${DESTDIR}/$(MANPATH)/man5/%.5: %.5
+ cp $< $@
+ chmod 444 $@
+
+-$(MANPATH)/man8/%.8: %.8
++${DESTDIR}/$(MANPATH)/man8/%.8: %.8
+ cp $< $@
+ chmod 444 $@
+
+-$(MANPATH)/man8/mdnsd.8: $(SHAREDDIR)/mDNSResponder.8
++${DESTDIR}/$(MANPATH)/man8/mdnsd.8: $(SHAREDDIR)/mDNSResponder.8
+ cp $< $@
+ chmod 444 $@
+