summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-03-28 22:01:31 +0000
committerMichael Imhof <tantive@gentoo.org>2003-03-28 22:01:31 +0000
commit291234022ea59036ffa3468dfcbb501e1ceae8b9 (patch)
tree873777b2c4b872d0533225fb9b0d2e1910245af1 /net-misc/mico
parentBug fix revision. (diff)
downloadgentoo-2-291234022ea59036ffa3468dfcbb501e1ceae8b9.tar.gz
gentoo-2-291234022ea59036ffa3468dfcbb501e1ceae8b9.tar.bz2
gentoo-2-291234022ea59036ffa3468dfcbb501e1ceae8b9.zip
Version bumped. Should close #18374
Diffstat (limited to 'net-misc/mico')
-rw-r--r--net-misc/mico/ChangeLog9
-rw-r--r--net-misc/mico/files/digest-mico-2.3.91
-rw-r--r--net-misc/mico/mico-2.3.9.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
index 77fa147d43f9..4b65c1e96d69 100644
--- a/net-misc/mico/ChangeLog
+++ b/net-misc/mico/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/mico
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.2 2003/02/12 08:27:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.3 2003/03/28 22:01:31 tantive Exp $
+
+*mico-2.3.9 (28 Mar 2003)
+
+ 28 Mar 2003; Michael Imhof <tantive@gentoo.org> ChangeLog,
+ mico-2.3.9.ebuild, files/digest-mico-2.3.9 :
+ Version bumped, thanks to Theofilos Intzoglou <oscar10@yifan.net>.
+ Should close #18374
*mico-2.3.7 (11 Dec 2002)
diff --git a/net-misc/mico/files/digest-mico-2.3.9 b/net-misc/mico/files/digest-mico-2.3.9
new file mode 100644
index 000000000000..7f460e1b71e9
--- /dev/null
+++ b/net-misc/mico/files/digest-mico-2.3.9
@@ -0,0 +1 @@
+MD5 292a755ce9d3d8856159d4abff29512f mico-2.3.9.tar.gz 2443134
diff --git a/net-misc/mico/mico-2.3.9.ebuild b/net-misc/mico/mico-2.3.9.ebuild
new file mode 100644
index 000000000000..c47545ce38b7
--- /dev/null
+++ b/net-misc/mico/mico-2.3.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.9.ebuild,v 1.1 2003/03/28 22:01:31 tantive Exp $
+
+IUSE="ssl tcltk"
+
+DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
+HOMEPAGE="http://www.mico.org/"
+SRC_URI="http://www.mico.org/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+DEPEND="virtual/glibc
+ sys-devel/flex
+ sys-devel/bison
+ ssl? ( dev-libs/openssl )
+ tcltk? ( dev-lang/tcl )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ local myopts="--enable-final
+ --disable-mini-stl
+ --enable-except
+ --enable-dynamic
+ --enable-repo
+ --enable-shared"
+
+ myopts="${myopts}
+ --enable-life
+ --enable-externalize"
+
+ use ssl && myopts="${myopts} --with-ssl=/usr" \
+ || myopts="${myopts} --without-ssl"
+ use tcltk && myopts="${myopts} --with-tcl=/usr" \
+ || myopts="${myopts} --without-tcl"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make INSTDIR=${D}/usr SHARED_INSTDIR=${D}/usr install || die
+
+ dodir /usr/share/
+ mv ${D}/usr/man ${D}/usr/share
+ dodir /usr/share/doc/
+ mv ${D}/usr/doc ${D}/usr/share/doc/${P}
+
+ dodoc CHANGES CONVERT FAQ INSTALL LICENSE* MANIFEST README* ROADMAP TODO VERSION
+}