summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-05-13 21:41:22 +0000
committerStuart Herbert <stuart@gentoo.org>2004-05-13 21:41:22 +0000
commit04a3277392c4612fa69d318590fabb783f91fd15 (patch)
tree6dcac1640c2b31b7373535f7b53f4921c4805afc /net-misc/nxcomp/nxcomp-1.3.2.ebuild
parentmarked 1.5.0 as stable on x86 (Manifest recommit) (diff)
downloadgentoo-2-04a3277392c4612fa69d318590fabb783f91fd15.tar.gz
gentoo-2-04a3277392c4612fa69d318590fabb783f91fd15.tar.bz2
gentoo-2-04a3277392c4612fa69d318590fabb783f91fd15.zip
Version bump
Diffstat (limited to 'net-misc/nxcomp/nxcomp-1.3.2.ebuild')
-rw-r--r--net-misc/nxcomp/nxcomp-1.3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/nxcomp/nxcomp-1.3.2.ebuild b/net-misc/nxcomp/nxcomp-1.3.2.ebuild
new file mode 100644
index 000000000000..15c743a58dc2
--- /dev/null
+++ b/net-misc/nxcomp/nxcomp-1.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcomp/nxcomp-1.3.2.ebuild,v 1.1 2004/05/13 21:41:22 stuart Exp $
+
+MY_P="${PN}-1.3.2-4"
+DESCRIPTION="X11 protocol compression library"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="http://www.nomachine.com/download/nxsources/nxcomp/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+DEPEND=">=media-libs/jpeg-6b-r3
+>=media-libs/libpng-1.2.5-r4
+>=sys-devel/gcc-3.2.3-r2
+>=sys-libs/glibc-2.3.2-r3
+>=sys-libs/zlib-1.1.4-r2
+virtual/x11"
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ ./configure
+ DISTCC_HOSTS="localhost" CCACHE_DISABLE="1" emake || die "compile problem"
+}
+
+src_install() {
+ insinto /usr/NX/lib
+ dolib libXcomp.so.1.3.0
+
+ dodoc README README-IPAQ LICENSE VERSION
+
+ insinto /usr/NX/include
+ doins NX.h
+}