summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-02-24 13:55:54 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-02-24 13:55:54 +0000
commit8a73beee4d8a2ed6a194a1f0531b819c8bc44415 (patch)
tree4f94904a647f29b2d24d9c1fe328df2adc552fa5 /net-misc/ocsync
parentStable for amd64 wrt bug #286239 (diff)
downloadgentoo-2-8a73beee4d8a2ed6a194a1f0531b819c8bc44415.tar.gz
gentoo-2-8a73beee4d8a2ed6a194a1f0531b819c8bc44415.tar.bz2
gentoo-2-8a73beee4d8a2ed6a194a1f0531b819c8bc44415.zip
Put back older version for pyowncloud (#501228) update blockers on owncloud-client
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/ocsync')
-rw-r--r--net-misc/ocsync/ChangeLog9
-rw-r--r--net-misc/ocsync/ocsync-0.90.4.ebuild58
-rw-r--r--net-misc/ocsync/ocsync-0.91.4.ebuild5
3 files changed, 69 insertions, 3 deletions
diff --git a/net-misc/ocsync/ChangeLog b/net-misc/ocsync/ChangeLog
index d6b7a5b25431..76992c59c370 100644
--- a/net-misc/ocsync/ChangeLog
+++ b/net-misc/ocsync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/ocsync
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ocsync/ChangeLog,v 1.3 2014/02/10 13:41:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ocsync/ChangeLog,v 1.4 2014/02/24 13:55:54 voyageur Exp $
+
+*ocsync-0.90.4 (24 Feb 2014)
+
+ 24 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org> +ocsync-0.90.4.ebuild,
+ ocsync-0.91.4.ebuild:
+ Put back older version for pyowncloud (#501228) update blockers on
+ owncloud-client
10 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org> ocsync-0.91.4.ebuild:
Fix compilation with USE=-iconv (and enable USE=iconv by default), restrict
diff --git a/net-misc/ocsync/ocsync-0.90.4.ebuild b/net-misc/ocsync/ocsync-0.90.4.ebuild
new file mode 100644
index 000000000000..5f7bf33336de
--- /dev/null
+++ b/net-misc/ocsync/ocsync-0.90.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ocsync/ocsync-0.90.4.ebuild,v 1.1 2014/02/24 13:55:54 voyageur Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A file synchronizer especially designed for you, the normal user"
+HOMEPAGE="http://csync.org/"
+SRC_URI="http://download.owncloud.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv samba +sftp test"
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/iniparser-3.1
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh )
+ !net-misc/csync
+ !>=net-misc/owncloud-client-1.5.1
+"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check dev-util/cmocka )
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/ocsync:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba Libsmbclient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}/usr/etc/ocsync" "${D}/etc/"
+ rm -r "${D}/usr/etc/"
+}
diff --git a/net-misc/ocsync/ocsync-0.91.4.ebuild b/net-misc/ocsync/ocsync-0.91.4.ebuild
index 949fc7343834..4496e0d218cc 100644
--- a/net-misc/ocsync/ocsync-0.91.4.ebuild
+++ b/net-misc/ocsync/ocsync-0.91.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ocsync/ocsync-0.91.4.ebuild,v 1.3 2014/02/10 13:41:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ocsync/ocsync-0.91.4.ebuild,v 1.4 2014/02/24 13:55:54 voyageur Exp $
EAPI=5
@@ -23,7 +23,8 @@ RDEPEND=">=dev-db/sqlite-3.4:3
iconv? ( virtual/libiconv )
samba? ( >=net-fs/samba-3.5 )
sftp? ( >=net-libs/libssh-0.5 )
- !net-misc/csync"
+ !net-misc/csync
+ !>=net-misc/owncloud-client-1.5.1"
DEPEND="${DEPEND}
doc? (
app-doc/doxygen