summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-22 14:38:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-22 14:38:24 +0000
commit4f1daf4f8084c7bd648a5116e958b1da6bf00ca5 (patch)
tree9ef55877c02e59a09477e99bd4178d2124b176e5 /net-misc/openntpd/openntpd-3.6_p1.ebuild
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-4f1daf4f8084c7bd648a5116e958b1da6bf00ca5.tar.gz
gentoo-2-4f1daf4f8084c7bd648a5116e958b1da6bf00ca5.tar.bz2
gentoo-2-4f1daf4f8084c7bd648a5116e958b1da6bf00ca5.zip
Add proper USE=ssl support #75292 by Koon.
Diffstat (limited to 'net-misc/openntpd/openntpd-3.6_p1.ebuild')
-rw-r--r--net-misc/openntpd/openntpd-3.6_p1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-misc/openntpd/openntpd-3.6_p1.ebuild b/net-misc/openntpd/openntpd-3.6_p1.ebuild
index 6e998f53deae..76121e3f88c5 100644
--- a/net-misc/openntpd/openntpd-3.6_p1.ebuild
+++ b/net-misc/openntpd/openntpd-3.6_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/openntpd-3.6_p1.ebuild,v 1.7 2004/12/17 14:51:35 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/openntpd-3.6_p1.ebuild,v 1.8 2004/12/22 14:38:24 vapier Exp $
inherit eutils
@@ -12,9 +12,10 @@ SRC_URI="mirror://openbsd/OpenNTPD/portable/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 sparc x86"
-IUSE=""
+IUSE="ssl"
RDEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )
!<=net-misc/ntp-4.2.0-r2"
DEPEND="${RDEPEND}
>=sys-apps/portage-2.0.51"
@@ -33,6 +34,11 @@ src_unpack() {
epatch ${FILESDIR}/${PV}-ntpd.8.patch
}
+src_compile() {
+ econf $(use_with !ssl builtin-arc4random) || die
+ emake || die "emake failed"
+}
+
src_install() {
make install DESTDIR="${D}" || die
dodoc ChangeLog CREDITS README