summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-04 23:20:50 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-04 23:20:50 +0000
commit46f942cbf742304942d12f0d64794d50f134ed70 (patch)
treedab03ec83a689db4d0224556e31136bba8142999 /net-misc/openssh
parentFixes #2514. (diff)
downloadgentoo-2-46f942cbf742304942d12f0d64794d50f134ed70.tar.gz
gentoo-2-46f942cbf742304942d12f0d64794d50f134ed70.tar.bz2
gentoo-2-46f942cbf742304942d12f0d64794d50f134ed70.zip
New revision. Changes submitted by Alson van der Meulen gentoo@alm.xs4all.nl
within bug #3391 were added. Bug closed/fixed.
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog9
-rw-r--r--net-misc/openssh/files/digest-openssh-3.2.3_p1-r11
-rw-r--r--net-misc/openssh/openssh-3.2.3_p1-r1.ebuild58
3 files changed, 67 insertions, 1 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index f43ee378f254..46009692dc56 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openssh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.7 2002/05/31 02:22:41 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.8 2002/06/04 23:20:50 stroke Exp $
+
+*openssh-3.2.3_p1-1 (5 June 2002)
+
+ 5 June 2002; Gabriele Giorgetti <stroke@gentoo.org> :
+
+ New revision. Changes submitted by Alson van der Meulen gentoo@alm.xs4all.nl
+ within bug #3391 were added. Bug closed/fixed.
*openssh-3.2.3_p1 (30 May 2002)
diff --git a/net-misc/openssh/files/digest-openssh-3.2.3_p1-r1 b/net-misc/openssh/files/digest-openssh-3.2.3_p1-r1
new file mode 100644
index 000000000000..d25ced5462f8
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-3.2.3_p1-r1
@@ -0,0 +1 @@
+MD5 f153ccdb5a91fa06ec78d0c6313f4d77 openssh-3.2.3p1.tar.gz 823051
diff --git a/net-misc/openssh/openssh-3.2.3_p1-r1.ebuild b/net-misc/openssh/openssh-3.2.3_p1-r1.ebuild
new file mode 100644
index 000000000000..70217928ace6
--- /dev/null
+++ b/net-misc/openssh/openssh-3.2.3_p1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.2.3_p1-r1.ebuild,v 1.1 2002/06/04 23:20:50 stroke Exp $
+
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="http://www.openssh.com/"
+
+# openssh recognizes when openssl has been slightly upgraded and refuses to run.
+# This new rev will use the new openssl.
+RDEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.73 >=sys-apps/shadow-4.0.2-r2 )
+ >=dev-libs/openssl-0.9.6d
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ sys-apps/groff
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+
+SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${PARCH}.tar.gz"
+S=${WORKDIR}/${PARCH}
+
+src_compile() {
+ local myconf
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use pam || myconf="${myconf} --without-pam"
+ use pam && myconf="${myconf} --with-pam"
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/ssh \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ if [ "`use static`" ]
+ then
+ # statically link to libcrypto -- good for the boot cd
+ perl -pi -e "s|-lcrypto|/usr/lib/libcrypto.a|g" Makefile
+ fi
+
+ make || die " compile problem"
+}
+
+src_install() {
+ make install-files DESTDIR=${D} || die
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+ insinto /etc/pam.d ; newins ${FILESDIR}/sshd.pam sshd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/sshd.rc6 sshd
+}