summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-11-01 22:41:58 +0000
committerJeroen Roovers <jer@gentoo.org>2009-11-01 22:41:58 +0000
commit7f61e658a1af8e9fa12b3762779def93ee24443d (patch)
tree6ea9c0291543265487c7a175c203309cbd887ec4 /net-misc/packETH/files
parentFix manifest (diff)
downloadgentoo-2-7f61e658a1af8e9fa12b3762779def93ee24443d.tar.gz
gentoo-2-7f61e658a1af8e9fa12b3762779def93ee24443d.tar.bz2
gentoo-2-7f61e658a1af8e9fa12b3762779def93ee24443d.zip
Version bump thanks to DrChandra (bug #260381). Respect CC, CFLAGS, LDFLAGS, and point to proper pixmaps directory.
(Portage version: 2.2_rc48/cvs/Linux i686)
Diffstat (limited to 'net-misc/packETH/files')
-rw-r--r--net-misc/packETH/files/packETH-1.6.3-gentoo.patch25
-rw-r--r--net-misc/packETH/files/packETH-1.6.3-pixmaps.patch11
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/packETH/files/packETH-1.6.3-gentoo.patch b/net-misc/packETH/files/packETH-1.6.3-gentoo.patch
new file mode 100644
index 000000000000..cd336673e685
--- /dev/null
+++ b/net-misc/packETH/files/packETH-1.6.3-gentoo.patch
@@ -0,0 +1,25 @@
+--- packETH-1.6.3/Makefile.orig 2009-01-20 16:07:51.000000000 +0100
++++ packETH-1.6.3/Makefile 2009-11-01 23:22:52.000000000 +0100
+@@ -22,17 +22,15 @@
+ prefix = /usr
+ includedir = /usr/src/include
+
++packages = gthread-2.0 gtk+-x11-2.0
++
+ INSTALL = /usr/bin/install -c
+ INSTALL_DATA = ${INSTALL} -m 644
+ INSTALL_PREFIX = /usr
+
+-CC = gcc
+-CPPFLAGS = -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
+-LDFLAGS =
+-CFLAGS = -g -O2 -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
+-#LIBS = -L/usr/lib -L/usr/X11R6/lib -lgtk -lgdk -lglib -lXi -lXext -lX11 -lm -lpthread -lgthread
+-#LIBS = -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lpthread -lgthread-2.0
+-LIBS = -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lgobject-2.0 -lglib-2.0 -lpthread -lgthread-2.0
++CPPFLAGS = $(shell pkg-config --cflags $(packages))
++CFLAGS += -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
++LIBS = $(shell pkg-config --libs $(packages))
+
+ SOURCES = \
+ main.c \
diff --git a/net-misc/packETH/files/packETH-1.6.3-pixmaps.patch b/net-misc/packETH/files/packETH-1.6.3-pixmaps.patch
new file mode 100644
index 000000000000..035755880ab8
--- /dev/null
+++ b/net-misc/packETH/files/packETH-1.6.3-pixmaps.patch
@@ -0,0 +1,11 @@
+--- packETH-1.6.3/interface.c.orig 2009-10-23 17:24:31.000000000 +0200
++++ packETH-1.6.3/interface.c 2009-11-01 23:27:22.000000000 +0100
+@@ -914,6 +914,8 @@
+ GtkWidget *label251;
+ GtkWidget *statusbar1;
+
++ add_pixmap_directory ("/usr/share/pixmaps/packETH");
++
+ window1 = gtk_window_new (GTK_WINDOW_TOPLEVEL);
+ gtk_window_set_title (GTK_WINDOW (window1), _("PackETH - ethernet packet generator"));
+ gtk_window_set_position (GTK_WINDOW (window1), GTK_WIN_POS_CENTER);