summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-19 13:20:37 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-19 13:20:37 +0000
commit01827e71ad993edf05b1e664733843477ad32035 (patch)
tree6a7232962b486383f31f7585d06072aa7ec2c66d /net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild
parent[bump] virtual/perl-Filter-1.410.0 (diff)
downloadgentoo-2-01827e71ad993edf05b1e664733843477ad32035.tar.gz
gentoo-2-01827e71ad993edf05b1e664733843477ad32035.tar.bz2
gentoo-2-01827e71ad993edf05b1e664733843477ad32035.zip
Fix PCRE support (bug #262504#c34 by Richard Grenville), install icon for menu entry.
(Portage version: 2.1.10.46/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild')
-rw-r--r--net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild b/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild
index 77fb54a8b577..ff5fac00974e 100644
--- a/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild
+++ b/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild,v 1.2 2012/02/17 08:13:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild,v 1.3 2012/02/19 13:20:37 pacho Exp $
EAPI=4
@@ -15,10 +15,11 @@ SRC_URI="http://dev.gentoo.org/~pacho/maintainer-needed/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug gtk hammer ipv6 nls profile ssl"
+IUSE="debug gtk hammer ipv6 nls pcre profile ssl"
RDEPEND="virtual/libintl
gtk? ( x11-libs/gtk+:2 )
+ pcre? ( dev-libs/libpcre )
ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}
@@ -31,6 +32,7 @@ AUTOTOOLS_IN_SOURCE_BUILD=1
DOCS=( README CREDITS NEWS AUTHORS BUGS TODO MAILINGLIST wget-pavuk.HOWTO
ChangeLog wget-pavuk.HOWTO pavuk_authinfo.sample pavukrc.sample
)
+
src_prepare() {
# Fixes a bug in Makefile.am that causes aclocal to fail
sed -i 's/^\(ACLOCAL_AMFLAGS[[:space:]]*=[[:space:]]*-I[[:space:]]*\)\$(top_srcdir)\//\1/' "${S}/Makefile.am" || die
@@ -38,6 +40,9 @@ src_prepare() {
# Fixes a bug in configure.in that breaks non-debug builds
sed -i 's/\([[:space:]]C\(PP\)*FLAGS=`\)/true; # \1/' "${S}/configure.in" || die
+ # Fixes a bug in re.c for PCRE support
+ epatch "${FILESDIR}/${P}-pcre-fix.patch"
+
# Fix for building with ~dev-lang/spidermonkey-1.8.5
# sed -i 's/mozjs/mozjs185/g' "${S}/configure.in" || die
@@ -45,11 +50,15 @@ src_prepare() {
}
src_configure() {
+ local regex="auto"
+ use pcre && regex="pcre"
+
local myeconfargs=(
--enable-threads
--enable-socks
--enable-utf-8
--disable-js
+ "--with-regex=${regex}"
$(use_enable gtk)
$(use_enable gtk gtk2)
$(use_enable gtk gnome)
@@ -64,15 +73,6 @@ src_configure() {
$(use_enable profile profiling)
)
- # PCRE support: Broken!
- # =====================
-
- # if use pcre; then
- # myeconfargs=($myeconfargs --with-regex=pcre)
- # else
- myeconfargs+=( "--with-regex=auto" )
- # fi
-
# JavaScript bindings: Broken!
# ============================
# Currently could pass configure phase with ~dev-lang/spidermonkey-1.8.5
@@ -92,7 +92,11 @@ src_configure() {
}
src_install() {
- use gtk && domenu "${S}/pavuk.desktop"
+ if use gtk; then
+ newicon src/pavuk_logo.xpm pavuk.xpm
+ domenu pavuk.desktop
+ fi
+
doman "${S}/doc/pavuk.1"
autotools-utils_src_install