summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-01 00:55:50 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-01 00:55:50 +0000
commitd4bdafc8c77ee89cd208d4a603d372c3d3c7f95b (patch)
tree1c0f044694548fe66b56f7aa2ba382886c95acab /net-misc/putty
parentwhitespace (diff)
downloadgentoo-2-d4bdafc8c77ee89cd208d4a603d372c3d3c7f95b.tar.gz
gentoo-2-d4bdafc8c77ee89cd208d4a603d372c3d3c7f95b.tar.bz2
gentoo-2-d4bdafc8c77ee89cd208d4a603d372c3d3c7f95b.zip
Snapshot version bump for GTK+ v2 support thanks to Iskren Slavov (bug #302860). Maintain it too.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog11
-rw-r--r--net-misc/putty/metadata.xml12
-rw-r--r--net-misc/putty/putty-0.60_p20100131.ebuild60
3 files changed, 76 insertions, 7 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 4451ceffc317..2c30f888d46d 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/putty
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.44 2009/08/18 15:22:47 vostorga Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.45 2010/02/01 00:55:50 jer Exp $
+
+*putty-0.60_p20100131 (01 Feb 2010)
+
+ 01 Feb 2010; Jeroen Roovers <jer@gentoo.org> +putty-0.60_p20100131.ebuild,
+ metadata.xml:
+ Snapshot version bump for GTK+ v2 support thanks to Iskren Slavov (bug
+ #302860). Maintain it too.
18 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> putty-0.60.ebuild:
Adding die to helper functions, bug #281323
diff --git a/net-misc/putty/metadata.xml b/net-misc/putty/metadata.xml
index 98b92e988672..a98f9e3a7691 100644
--- a/net-misc/putty/metadata.xml
+++ b/net-misc/putty/metadata.xml
@@ -3,12 +3,14 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
</maintainer>
<longdescription lang="en">
- This is the Unix port of the popular Windows ssh client, PuTTY. It
- supports flexible terminal setup, mid-session reconfiguration using
- Ctrl-rightclick, multiple X11 authentication protocols, and various
- other interesting things not provided by ssh in an xterm.
+ PuTTY is a free implementation of Telnet and SSH for Windows and Unix
+ platforms, along with an xterm terminal emulator. It supports flexible
+ terminal setup, mid-session reconfiguration using Ctrl-rightclick,
+ multiple X11 authentication protocols, and various other interesting
+ things not provided by ssh in an xterm.
</longdescription>
</pkgmetadata>
diff --git a/net-misc/putty/putty-0.60_p20100131.ebuild b/net-misc/putty/putty-0.60_p20100131.ebuild
new file mode 100644
index 000000000000..f025e678b520
--- /dev/null
+++ b/net-misc/putty/putty-0.60_p20100131.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.60_p20100131.ebuild,v 1.1 2010/02/01 00:55:50 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ kerberos? ( app-crypt/mit-krb5 )
+ !x11-terms/pssh
+"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+S="${WORKDIR}/putty-0.60-2010-01-31"
+
+src_prepare() {
+ cd "${S}"/unix || die "cd unix failed"
+ sed -i configure.ac -e '/^AM_PATH_GTK(/d' || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die "cd failed"
+ econf \
+ $(use_with kerberos gssapi) \
+ || die "econf failed"
+}
+
+src_compile() {
+ cd "${S}"/unix || die "cd unix failed"
+ emake \
+ $(use ipv6 || echo COMPAT=-DNO_IPV6) \
+ VER=-DSNAPSHOT=${PV} \
+ || die "emake failed"
+}
+
+src_install() {
+ if use doc; then
+ dodoc puttydoc.txt || die "dodoc failed"
+ dohtml doc/*.html || die "dohtml failed"
+ fi
+
+ cd "${S}"/unix
+ emake DESTDIR="${D}" install || die "install failed"
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry "putty" "PuTTY" putty "Network"
+}