summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2003-08-03 00:05:09 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2003-08-03 00:05:09 +0000
commitf6bbf295b57fb4f3d6f1090c047d38a51cb0b938 (patch)
tree322f401727c91bbebbe6f7bd0563f48bd54b17d5 /net-misc/pxes/files
parentInitial import (diff)
downloadgentoo-2-f6bbf295b57fb4f3d6f1090c047d38a51cb0b938.tar.gz
gentoo-2-f6bbf295b57fb4f3d6f1090c047d38a51cb0b938.tar.bz2
gentoo-2-f6bbf295b57fb4f3d6f1090c047d38a51cb0b938.zip
Initial import
Diffstat (limited to 'net-misc/pxes/files')
-rw-r--r--net-misc/pxes/files/digest-pxes-0.64
-rw-r--r--net-misc/pxes/files/makedevices.sh93
-rw-r--r--net-misc/pxes/files/pxes-0.6-gentoo.patch24
3 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/pxes/files/digest-pxes-0.6 b/net-misc/pxes/files/digest-pxes-0.6
new file mode 100644
index 000000000000..5f46d40b3f26
--- /dev/null
+++ b/net-misc/pxes/files/digest-pxes-0.6
@@ -0,0 +1,4 @@
+MD5 ff233a9dd9f5fbb563b7ca5aed90c546 pxes-base-i586-0.6.tar.gz 12408010
+MD5 48f3b47631b0b3676d5f3f08675697c2 pxesconfig-0.6.tar.gz 265782
+MD5 fc2d66cdfda1bb44c5de384001e303d4 pxelinux.0 10820
+MD5 1ee01ea37c265eb3037339a7d5a0630f pxes-ltsp-0.6.tar.gz 14498
diff --git a/net-misc/pxes/files/makedevices.sh b/net-misc/pxes/files/makedevices.sh
new file mode 100644
index 000000000000..b603484a4ea3
--- /dev/null
+++ b/net-misc/pxes/files/makedevices.sh
@@ -0,0 +1,93 @@
+#!/bin/bash
+
+DEV1=/opt/pxes-0.6/stock/dist/dev
+DEV2=/opt/pxes-0.6/stock/initrd/dev
+
+if [ ! -d ${DEV1} ]; then
+ mkdir -p ${DEV1}
+fi
+
+cd ${DEV1}
+mkdir input pts
+mknod agpgart c 10 175
+mknod audio0 c 14 4
+ln -s audio0 audio
+mknod console c 5 1
+mknod dsp c 14 3
+mknod dsp1 c 14 19
+for i in 0 1 2 3 4 5 6 7; do
+ mknod fb${i} c 29 $(( ${i} * 32 ))
+done
+ln -s fb0 fb
+mknod fd0 b 2 0
+mknod fd1 b 2 1
+mknod fd0H1440 b 2 28
+mknod gart c 174 0
+mknod hda b 3 0
+for i in 1 2 3 4 5 6 7 8 9; do
+ mknod hda${i} b 3 ${i}
+done
+mknod hdb b 3 64
+mknod hdc b 22 0
+ln -s hdc cdrom
+mknod hdd b 22 64
+mknod kbd c 11 0
+mknod lp0 c 6 0
+mknod lp1 c 6 1
+chmod 666 lp0 lp1
+chgrp lp lp0 lp1
+mknod mem c 1 1
+mknod mixer c 14 0
+mknod null c 1 3
+mknod openprm c 10 139
+mknod psaux c 10 1
+ln -s psaux mouse
+mknod ptmx c 5 2
+for i in 0 1 2 3 4 5 6 7 8 9; do
+ mknod ptyp${i} c 2 ${i}
+ chmod 666 ptyp${i}
+ chgrp tty ptyp${i}
+done
+mknod ram b 1 1
+mknod tty c 5 0
+chmod 666 tty
+for i in 0 1 2 3 4 5 6 7 8 9; do
+ mknod tty${i} c 4 ${i}
+done
+for i in 0 1 2 3; do
+ mknod ttyS${i} c 4 $(( ${i} + 64 ))
+ chgrp tty ttyS${i}
+done
+for i in 0 1 2 3 4 5 6 7 8 9; do
+ mknod ttyp${i} c 3 ${i}
+ chgrp tty ttyp${i}
+ chmod 666 ttyp${i}
+done
+mknod zero c 1 5
+cd input
+mknod keyboard c 10 150
+chmod 600 keyboard
+mknod mice c 13 63
+
+if [ ! -d ${DEV2} ]; then
+ mkdir -p ${DEV2}
+fi
+
+cd ${DEV2}
+mknod console c 5 1
+mknod hda b 3 0
+mknod hdb b 3 64
+mknod hdc b 22 0
+ln -s hdc cdrom
+mknod hdd b 22 64
+mknod lvm b 109 0
+mknod null c 1 3
+mknod ram b 1 1
+mknod sda2 b 8 2
+chgrp disk sda2
+chmod 660 sda2
+mknod systty c 4 0
+for i in 0 1 2 3 4; do
+ mknod tty${i} c 4 ${i}
+done
+mknod zero c 1 5
diff --git a/net-misc/pxes/files/pxes-0.6-gentoo.patch b/net-misc/pxes/files/pxes-0.6-gentoo.patch
new file mode 100644
index 000000000000..a397cd0cb0e1
--- /dev/null
+++ b/net-misc/pxes/files/pxes-0.6-gentoo.patch
@@ -0,0 +1,24 @@
+diff -urN pxesconfig-0.6/Makefile.PL pxesconfig-0.6-gentoo/Makefile.PL
+--- pxesconfig-0.6/Makefile.PL 2003-07-19 00:49:43.000000000 -0400
++++ pxesconfig-0.6-gentoo/Makefile.PL 2003-08-01 10:59:30.000000000 -0400
+@@ -130,7 +130,7 @@
+
+ install ::
+ \$(PERL) -MExtUtils::Install \\
+- -e "install({'Pxesconfig' => '\$(LIB)/Pxesconfig'},'\$(VERBINST)',0);"
++ -e "install({'Pxesconfig' => '\$(INSTALLARCHLIB)/Pxesconfig'},'\$(VERBINST)',0);"
+
+ checkpxesconfig:
+ \@if grep '^[ ]*use lib "\."' pxesconfig >/dev/null ; \\
+diff -urN pxesconfig-0.6/Pxesconfig/PxesconfigGUI.pm pxesconfig-0.6-gentoo/Pxesconfig/PxesconfigGUI.pm
+--- pxesconfig-0.6/Pxesconfig/PxesconfigGUI.pm 2003-07-19 00:49:44.000000000 -0400
++++ pxesconfig-0.6-gentoo/Pxesconfig/PxesconfigGUI.pm 2003-08-01 11:00:03.000000000 -0400
+@@ -55,7 +55,7 @@
+
+ # FIXME
+ # /opt prefix
+- $Glade::PerlRun::pixmaps_directory = "/opt/share/pixmaps/pxesconfig";
++ $Glade::PerlRun::pixmaps_directory = "/usr/share/pixmaps/pxesconfig";
+ #warn "pixmaps: $Glade::PerlRun::pixmaps_directory";
+ } # End of sub BEGIN
+