summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-01 19:16:56 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-01 19:16:56 +0000
commit13d0aa5610d7a26a7555dad9850b1ddb086c2c3d (patch)
treef80e550e133eed5a8ddcb8fe0e1112fe0a1ed646 /net-misc/rsnapshot
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-13d0aa5610d7a26a7555dad9850b1ddb086c2c3d.tar.gz
gentoo-2-13d0aa5610d7a26a7555dad9850b1ddb086c2c3d.tar.bz2
gentoo-2-13d0aa5610d7a26a7555dad9850b1ddb086c2c3d.zip
Initial ebuild.
Diffstat (limited to 'net-misc/rsnapshot')
-rw-r--r--net-misc/rsnapshot/ChangeLog9
-rw-r--r--net-misc/rsnapshot/Manifest2
-rw-r--r--net-misc/rsnapshot/files/digest-rsnapshot-1.1.01
-rw-r--r--net-misc/rsnapshot/rsnapshot-1.1.0.ebuild53
4 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/rsnapshot/ChangeLog b/net-misc/rsnapshot/ChangeLog
new file mode 100644
index 000000000000..acb5d559daf0
--- /dev/null
+++ b/net-misc/rsnapshot/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/rsnapshot
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsnapshot/ChangeLog,v 1.1 2004/03/01 19:16:56 mholzer Exp $
+
+*rsnapshot-1.1.0 (01 Mar 2004)
+
+ 01 Mar 2004; Martin Holzer <mholzer@gentoo.org> rsnapshot-1.1.0.ebuild:
+ Initial ebuild. Submitted by AgenT <jakub_sad@yahoo.com> in 40977.
+
diff --git a/net-misc/rsnapshot/Manifest b/net-misc/rsnapshot/Manifest
new file mode 100644
index 000000000000..b763ca6b0519
--- /dev/null
+++ b/net-misc/rsnapshot/Manifest
@@ -0,0 +1,2 @@
+MD5 e565a8060665d1ac767bb3813aaaff0e rsnapshot-1.1.0.ebuild 1183
+MD5 72b2d3805df87cc643ab774eeffa10bf files/digest-rsnapshot-1.1.0 66
diff --git a/net-misc/rsnapshot/files/digest-rsnapshot-1.1.0 b/net-misc/rsnapshot/files/digest-rsnapshot-1.1.0
new file mode 100644
index 000000000000..bc0caa6e0e73
--- /dev/null
+++ b/net-misc/rsnapshot/files/digest-rsnapshot-1.1.0
@@ -0,0 +1 @@
+MD5 27ed7e226f094e91cebe4f9300878315 rsnapshot-1.1.0.tar.gz 81986
diff --git a/net-misc/rsnapshot/rsnapshot-1.1.0.ebuild b/net-misc/rsnapshot/rsnapshot-1.1.0.ebuild
new file mode 100644
index 000000000000..fd082eec6d53
--- /dev/null
+++ b/net-misc/rsnapshot/rsnapshot-1.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsnapshot/rsnapshot-1.1.0.ebuild,v 1.1 2004/03/01 19:16:56 mholzer Exp $
+
+inherit eutils
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="rsnapshot is a filesystem backup utility based on rsync."
+HOMEPAGE="http://www.rsnapshot.org"
+SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-lang/perl-5.8.2
+ >=util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ >=net-misc/openssh-3.7.1_p2-r1
+ >=net-misc/rsync-2.6.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #autoconf || die "autoconf problem"
+}
+
+src_compile() {
+ econf \
+ --prefix=/usr \
+ --sysconfdir=/etc || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The configuration file: "
+ einfo " /etc/rsnapshot.conf.default "
+ einfo " has been installed. "
+ einfo "This is a template. "
+ einfo "Copy, or move, the above file to: "
+ einfo " /etc/rsnapshot.conf "
+ einfo "Note that upgrading will update "
+ einfo " the template, not real config. "
+ einfo
+}