summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Morales <soulse@gentoo.org>2005-10-17 05:58:55 +0000
committerMarco Morales <soulse@gentoo.org>2005-10-17 05:58:55 +0000
commit6acb90eca4b58be47f8cfced3a07aa896baf7e3c (patch)
treefa8cc0d0c58519d7cb00a9d1b7a68a810aca65f1 /net-misc/socat/socat-1.4.2.0-r1.ebuild
parentFix dos<->unix newlines in kernel-2.6-fixes.diff (diff)
downloadgentoo-2-6acb90eca4b58be47f8cfced3a07aa896baf7e3c.tar.gz
gentoo-2-6acb90eca4b58be47f8cfced3a07aa896baf7e3c.tar.bz2
gentoo-2-6acb90eca4b58be47f8cfced3a07aa896baf7e3c.zip
Rev bumps as per bug #109331.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-misc/socat/socat-1.4.2.0-r1.ebuild')
-rw-r--r--net-misc/socat/socat-1.4.2.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/socat/socat-1.4.2.0-r1.ebuild b/net-misc/socat/socat-1.4.2.0-r1.ebuild
new file mode 100644
index 000000000000..ccd05951cc00
--- /dev/null
+++ b/net-misc/socat/socat-1.4.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.4.2.0-r1.ebuild,v 1.1 2005/10/17 05:58:55 soulse Exp $
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+SRC_URI="http://www.dest-unreach.org/${PN}/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc x86"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ tcpd? (sys-apps/tcp-wrappers)
+ virtual/libc"
+
+S=${WORKDIR}/socat-${PV:0:3}
+
+src_compile() {
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ make install DESTDIR="${D}" || die
+
+ dodoc BUGREPORTS CHANGES DEVELOPMENT EXAMPLES \
+ FAQ FILES PORTING README SECURITY VERSION xio.help
+ docinto examples
+ dodoc *.sh
+ dohtml socat.html
+}