summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-01-17 20:24:33 +0000
committerJeroen Roovers <jer@gentoo.org>2010-01-17 20:24:33 +0000
commit5a5143f2c27defcb64e19493fbd0f7c6b6454685 (patch)
tree860adaa98857bd74ec6f71702df6ead9b7e3aefd /net-misc/socat
parentKeyword ~amd64, bug 301207 by Martin Väth. (diff)
downloadgentoo-2-5a5143f2c27defcb64e19493fbd0f7c6b6454685.tar.gz
gentoo-2-5a5143f2c27defcb64e19493fbd0f7c6b6454685.tar.bz2
gentoo-2-5a5143f2c27defcb64e19493fbd0f7c6b6454685.zip
Filter -Wno-error thanks to Didier Barvaux (bug #293324).
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/ChangeLog6
-rw-r--r--net-misc/socat/socat-1.7.1.1.ebuild4
-rw-r--r--net-misc/socat/socat-1.7.1.2.ebuild5
-rw-r--r--net-misc/socat/socat-2.0.0_beta3.ebuild5
4 files changed, 13 insertions, 7 deletions
diff --git a/net-misc/socat/ChangeLog b/net-misc/socat/ChangeLog
index fdeb20852e23..1d84195fc4d6 100644
--- a/net-misc/socat/ChangeLog
+++ b/net-misc/socat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/socat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.70 2010/01/13 21:58:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.71 2010/01/17 20:24:33 jer Exp $
+
+ 17 Jan 2010; Jeroen Roovers <jer@gentoo.org> socat-1.7.1.1.ebuild,
+ socat-1.7.1.2.ebuild, socat-2.0.0_beta3.ebuild:
+ Filter -Wno-error thanks to Didier Barvaux (bug #293324).
*socat-1.7.1.2 (13 Jan 2010)
diff --git a/net-misc/socat/socat-1.7.1.1.ebuild b/net-misc/socat/socat-1.7.1.1.ebuild
index 4e146c756b92..b8a4526e5edf 100644
--- a/net-misc/socat/socat-1.7.1.1.ebuild
+++ b/net-misc/socat/socat-1.7.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.1.1.ebuild,v 1.10 2010/01/01 12:28:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.1.1.ebuild,v 1.11 2010/01/17 20:24:33 jer Exp $
EAPI="2"
@@ -25,7 +25,7 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
- filter-flags -Wall
+ filter-flags -Wall -Wno-error*
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \
diff --git a/net-misc/socat/socat-1.7.1.2.ebuild b/net-misc/socat/socat-1.7.1.2.ebuild
index 562bf46e062c..7f624600aa34 100644
--- a/net-misc/socat/socat-1.7.1.2.ebuild
+++ b/net-misc/socat/socat-1.7.1.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.1.2.ebuild,v 1.1 2010/01/13 21:58:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.1.2.ebuild,v 1.2 2010/01/17 20:24:33 jer Exp $
EAPI="2"
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/"
@@ -25,6 +25,7 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
+ filter-flags -Wno-error*
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \
diff --git a/net-misc/socat/socat-2.0.0_beta3.ebuild b/net-misc/socat/socat-2.0.0_beta3.ebuild
index ba27268f3604..dd8a1064ca4b 100644
--- a/net-misc/socat/socat-2.0.0_beta3.ebuild
+++ b/net-misc/socat/socat-2.0.0_beta3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-2.0.0_beta3.ebuild,v 1.3 2010/01/01 12:28:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-2.0.0_beta3.ebuild,v 1.4 2010/01/17 20:24:33 jer Exp $
EAPI="2"
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/"
@@ -25,6 +25,7 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
+ filter-flags -Wall -Wno-error*
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \