summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-31 05:53:39 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-31 05:53:39 +0000
commit0acd479b6d07058b1d439aba957a29c4e53caf70 (patch)
treec3d6c27a45546543b4ddfa34fa8901f67cfdc4ae /net-misc/spice-gtk
parentmarked x86 per bug 418275 (diff)
downloadgentoo-2-0acd479b6d07058b1d439aba957a29c4e53caf70.tar.gz
gentoo-2-0acd479b6d07058b1d439aba957a29c4e53caf70.tar.bz2
gentoo-2-0acd479b6d07058b1d439aba957a29c4e53caf70.zip
fix for parallel install (bug #418295)
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/ChangeLog6
-rw-r--r--net-misc/spice-gtk/files/0.12-parallel-install.patch16
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.12.ebuild10
3 files changed, 29 insertions, 3 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index 2717029e6ae1..736e42b941ed 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.21 2012/05/29 05:07:19 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.22 2012/05/31 05:53:39 dev-zero Exp $
+
+ 31 May 2012; Tiziano Müller <dev-zero@gentoo.org>
+ +files/0.12-parallel-install.patch, spice-gtk-0.12.ebuild:
+ fix for parallel install (bug #418295)
29 May 2012; Tiziano Müller <dev-zero@gentoo.org> spice-gtk-0.12.ebuild:
Fix building with python-3 as default interpreter (bug #418017, thanks to
diff --git a/net-misc/spice-gtk/files/0.12-parallel-install.patch b/net-misc/spice-gtk/files/0.12-parallel-install.patch
new file mode 100644
index 000000000000..04a22bdf066d
--- /dev/null
+++ b/net-misc/spice-gtk/files/0.12-parallel-install.patch
@@ -0,0 +1,16 @@
+diff --git a/gtk/Makefile.am b/gtk/Makefile.am
+index 7b29e61..86b3939 100644
+--- a/gtk/Makefile.am
++++ b/gtk/Makefile.am
+@@ -505,6 +505,11 @@ vncdisplaykeymap_win322xtkbd.c:
+ if WITH_PYTHON
+ pyexec_LTLIBRARIES = SpiceClientGtk.la
+
++# workaround for broken parallel install support in automake with LTLIBRARIES
++# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7328
++install_pyexecLTLIBRARIES = install-pyexecLTLIBRARIES
++$(install_pyexecLTLIBRARIES): install-libLTLIBRARIES
++
+ SpiceClientGtk_la_LIBADD = libspice-client-gtk-2.0.la libspice-client-glib-2.0.la $(PYGTK_LIBS)
+ SpiceClientGtk_la_CFLAGS = $(GTK_CFLAGS) $(PYTHON_INCLUDES) $(PYGTK_CFLAGS) $(WARN_PYFLAGS)
+ SpiceClientGtk_la_LDFLAGS = -module -avoid-version -fPIC
diff --git a/net-misc/spice-gtk/spice-gtk-0.12.ebuild b/net-misc/spice-gtk/spice-gtk-0.12.ebuild
index 2b8c540c714e..3b189b0b4c07 100644
--- a/net-misc/spice-gtk/spice-gtk-0.12.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.12.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.12.ebuild,v 1.2 2012/05/29 05:07:19 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.12.ebuild,v 1.3 2012/05/31 05:53:39 dev-zero Exp $
EAPI="4"
GCONF_DEBUG="no"
-inherit eutils python
+inherit autotools eutils python
PYTHON_DEPEND="2"
@@ -69,6 +69,12 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-parallel-install.patch"
+ eaclocal
+ eautoreconf
+}
+
src_configure() {
local audio="no"
local gtk="2.0"