summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-20 13:56:01 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-20 13:56:01 +0000
commit68b14977d6b2111bd1855708fed402ceb5cac252 (patch)
treef4f8868e4faf4a8de663cf9382905b4b7a1f310c /net-misc/stone/stone-2.3e-r1.ebuild
parentFix USE=-gtk (where dev-libs/glib is still used, bug #456788). (diff)
downloadgentoo-2-68b14977d6b2111bd1855708fed402ceb5cac252.tar.gz
gentoo-2-68b14977d6b2111bd1855708fed402ceb5cac252.tar.bz2
gentoo-2-68b14977d6b2111bd1855708fed402ceb5cac252.zip
Revision bump: EAPI 5, base eclass, use flag-o-matic for CFLAGS handling, respect LDFLAGS, wrt bug #337879
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-misc/stone/stone-2.3e-r1.ebuild')
-rw-r--r--net-misc/stone/stone-2.3e-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/stone/stone-2.3e-r1.ebuild b/net-misc/stone/stone-2.3e-r1.ebuild
new file mode 100644
index 000000000000..704b86e198d2
--- /dev/null
+++ b/net-misc/stone/stone-2.3e-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/stone-2.3e-r1.ebuild,v 1.1 2013/02/20 13:56:01 pinkbyte Exp $
+
+EAPI=5
+
+inherit base eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A simple TCP/IP packet repeater"
+HOMEPAGE="http://www.gcd.org/sengoku/stone/"
+SRC_URI="http://www.gcd.org/sengoku/stone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-2.3d-2.3.2.7"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" ) # bug #337879
+
+src_prepare() {
+ tc-export CC
+ append-cflags "-D_GNU_SOURCE"
+
+ base_src_prepare
+}
+
+src_compile() {
+ local myargs
+ if use ssl ; then
+ myargs="SSL=/usr linux-ssl"
+ else
+ myargs="linux"
+ fi
+ emake ${myargs}
+}
+
+src_install() {
+ dobin stone
+ dodoc README*
+}