summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-04 16:12:38 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-04 16:12:38 +0000
commit043f98fcf48981a2a8456a81e7fd100837cb2e32 (patch)
treea531c5d09b2bd9b647e3fb414a450b012acd3a86 /net-misc/stone/stone-2.3e.ebuild
parentAllow planner to select specific libgda and fix build with newer glib/gcc, bu... (diff)
downloadgentoo-2-043f98fcf48981a2a8456a81e7fd100837cb2e32.tar.gz
gentoo-2-043f98fcf48981a2a8456a81e7fd100837cb2e32.tar.bz2
gentoo-2-043f98fcf48981a2a8456a81e7fd100837cb2e32.zip
Version bumped. Fixed glibc-2.8 issue, bug #241006.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'net-misc/stone/stone-2.3e.ebuild')
-rw-r--r--net-misc/stone/stone-2.3e.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/stone/stone-2.3e.ebuild b/net-misc/stone/stone-2.3e.ebuild
new file mode 100644
index 000000000000..6e6cbc7df03c
--- /dev/null
+++ b/net-misc/stone/stone-2.3e.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/stone-2.3e.ebuild,v 1.1 2008/12/04 16:12:38 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A simple TCP/IP packet repeater"
+HOMEPAGE="http://www.gcd.org/sengoku/stone/"
+SRC_URI="http://www.gcd.org/sengoku/stone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${PN}-2.3d-2.3.2.7"
+
+src_compile() {
+ local myargs
+
+ if use ssl ; then
+ myargs="${myconf} SSL=/usr linux-ssl"
+ else
+ myargs="${myconf} linux"
+ fi
+
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -D_GNU_SOURCE" \
+ ${myargs} || die
+}
+
+src_install() {
+ dobin stone
+ # doman stone.1
+ dodoc README*
+}