summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-06 07:00:43 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-06 07:00:43 +0000
commit76d7f3f2212eaf060bb5a3627d968ce8d25624f3 (patch)
tree4830b68faeae23c107565abb2ad64b8eb37af9de /net-misc/suite3270
parentVersion bump, update to EAPI5, drop old. (diff)
downloadgentoo-2-76d7f3f2212eaf060bb5a3627d968ce8d25624f3.tar.gz
gentoo-2-76d7f3f2212eaf060bb5a3627d968ce8d25624f3.tar.bz2
gentoo-2-76d7f3f2212eaf060bb5a3627d968ce8d25624f3.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-misc/suite3270')
-rw-r--r--net-misc/suite3270/ChangeLog10
-rw-r--r--net-misc/suite3270/suite3270-3.3.12_p10.ebuild101
2 files changed, 108 insertions, 3 deletions
diff --git a/net-misc/suite3270/ChangeLog b/net-misc/suite3270/ChangeLog
index 36f9dc9aae51..021f5f3176d1 100644
--- a/net-misc/suite3270/ChangeLog
+++ b/net-misc/suite3270/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/suite3270
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.41 2010/10/16 18:13:12 ranger Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.42 2012/12/06 07:00:43 vapier Exp $
+
+*suite3270-3.3.12_p10 (06 Dec 2012)
+
+ 06 Dec 2012; Mike Frysinger <vapier@gentoo.org> +suite3270-3.3.12_p10.ebuild:
+ Version bump.
16 Oct 2010; Brent Baude <ranger@gentoo.org>
suite3270-3.3.10_p3-r1.ebuild:
@@ -185,4 +190,3 @@
27 Jul 2003; Robin H. Johnson <robbat2@gentoo.org> suite3270-3.2.20.ebuild:
Initial Commit.
-
diff --git a/net-misc/suite3270/suite3270-3.3.12_p10.ebuild b/net-misc/suite3270/suite3270-3.3.12_p10.ebuild
new file mode 100644
index 000000000000..870a534afe6d
--- /dev/null
+++ b/net-misc/suite3270/suite3270-3.3.12_p10.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.12_p10.ebuild,v 1.1 2012/12/06 07:00:43 vapier Exp $
+
+EAPI="4"
+
+MY_PV=${PV/_p/ga}
+MY_P=${PN}-${MY_PV}
+SUB_PV=${PV:0:3}
+
+S=${WORKDIR}
+
+# only the x3270 package installs fonts
+FONT_PN="x3270"
+FONT_S=${WORKDIR}/${FONT_PN}-${SUB_PV}
+
+inherit eutils font multiprocessing
+
+DESCRIPTION="Complete 3270 access package"
+HOMEPAGE="http://x3270.bgp.nu/"
+SRC_URI="mirror://sourceforge/x3270/${MY_P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE="cjk doc ncurses ssl tcl X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ )
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-misc/imake
+ x11-misc/xbitmaps
+ x11-proto/xproto
+ app-text/rman
+ x11-apps/mkfontdir
+ x11-apps/bdftopcf
+ )"
+
+suite3270_makelist() {
+ echo pr3287 s3270 \
+ $(usex ncurses c3270 '') \
+ $(usex tcl tcl3270 '') \
+ $(usex X x3270 '')
+}
+
+src_configure() {
+ local p myconf
+ # Run configures in parallel!
+ multijob_init
+ for p in $(suite3270_makelist) ; do
+ cd "${S}/${p}-${SUB_PV}"
+ if [[ ${p} == "x3270" ]] ; then
+ myconf=(
+ $(use_with X x)
+ $(use_with X fontdir "${FONTDIR}")
+ )
+ else
+ myconf=()
+ fi
+ multijob_child_init econf \
+ --cache-file="${S}"/config.cache \
+ $(use_enable cjk dbcs) \
+ $(use_enable ssl) \
+ "${myconf[@]}"
+ done
+ multijob_finish
+}
+
+src_compile() {
+ local p
+ for p in $(suite3270_makelist) ; do
+ emake -C "${S}/${p}-${SUB_PV}"
+ done
+}
+
+src_install() {
+ use X && dodir "${FONTDIR}"
+ local p
+ for p in $(suite3270_makelist) ; do
+ cd "${S}/${p}-${SUB_PV}"
+ emake DESTDIR="${D}" install install.man
+ docinto ${p}
+ local d=$(echo README*)
+ [[ -n ${d} ]] && dodoc ${d}
+ use doc && dohtml html/*
+ done
+ chmod a-x "${D}"/usr/share/man/*/*
+
+ use X && font_src_install
+}
+
+pkg_postinst() { use X && font_pkg_postinst ; }
+pkg_postrm() { use X && font_pkg_postrm ; }