summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2009-04-20 18:52:22 +0000
committerSerkan Kaba <serkan@gentoo.org>2009-04-20 18:52:22 +0000
commit28ee536de0f9dac0242f61212bcf8b80d8f4bd17 (patch)
treeba1f7dec7305358e577a87396dbd08e9b1a38554 /net-misc/tightvnc
parentVersion bump (diff)
downloadgentoo-2-28ee536de0f9dac0242f61212bcf8b80d8f4bd17.tar.gz
gentoo-2-28ee536de0f9dac0242f61212bcf8b80d8f4bd17.tar.bz2
gentoo-2-28ee536de0f9dac0242f61212bcf8b80d8f4bd17.zip
Add files needed for applet hosted mode. Thanks to Richard F. Ostrow Jr. <kshots@warfaresdl.com> for the report and help. Fixes bug #259490.
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tightvnc')
-rw-r--r--net-misc/tightvnc/ChangeLog10
-rw-r--r--net-misc/tightvnc/tightvnc-1.3.10-r1.ebuild131
-rw-r--r--net-misc/tightvnc/tightvnc-1.3.9-r3.ebuild131
3 files changed, 271 insertions, 1 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index 1e905a69a604..c07fcf23f997 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.134 2009/04/18 17:39:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.135 2009/04/20 18:52:22 serkan Exp $
+
+*tightvnc-1.3.10-r1 (20 Apr 2009)
+*tightvnc-1.3.9-r3 (20 Apr 2009)
+
+ 20 Apr 2009; Serkan Kaba <serkan@gentoo.org> +tightvnc-1.3.9-r3.ebuild,
+ +tightvnc-1.3.10-r1.ebuild:
+ Add files needed for applet hosted mode. Thanks to Richard F. Ostrow Jr.
+ <kshots@warfaresdl.com> for the report and help. Fixes bug #259490.
18 Apr 2009; Raúl Porcel <armin76@gentoo.org> tightvnc-1.3.10.ebuild:
alpha/arm/sh/sparc/x86 stable wrt #266660
diff --git a/net-misc/tightvnc/tightvnc-1.3.10-r1.ebuild b/net-misc/tightvnc/tightvnc-1.3.10-r1.ebuild
new file mode 100644
index 000000000000..4e04a8505333
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.3.10-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.3.10-r1.ebuild,v 1.1 2009/04/20 18:52:22 serkan Exp $
+
+inherit eutils toolchain-funcs java-pkg-opt-2
+
+IUSE="java tcpd server"
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2
+ java? ( mirror://sourceforge/vnc-tight/${P}_javasrc.tar.gz )"
+HOMEPAGE="http://www.tightvnc.com/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~sh ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+CDEPEND="~media-libs/jpeg-6b
+ server? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ x11-apps/rgb
+ x11-apps/xauth
+ x11-apps/xsetroot
+ )
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXt
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ x11-proto/xextproto
+ x11-proto/xproto
+ server? (
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/printproto
+ )
+ >=x11-misc/imake-1
+ x11-misc/gccmakedep
+ x11-misc/makedepend
+ !net-misc/vnc"
+
+src_unpack() {
+
+ if ! use server;
+ then
+ echo
+ einfo "The 'server' USE flag will build tightvnc's server."
+ einfo "If '-server' is chosen only the client is built to save space."
+ einfo "Stop the build now if you need to add 'server' to USE flags.\n"
+ ebeep
+ epause 5
+ fi
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.3.10-pathfixes.patch" # fixes bug 78385 and 146099
+ epatch "${FILESDIR}/${PN}-1.3.8-imake-tmpdir.patch" # fixes bug 23483
+ epatch "${FILESDIR}/${PN}-1.3.8-darwin.patch" # fixes bug 89908
+ epatch "${FILESDIR}/${PN}-1.3.8-mips.patch"
+ epatch "${FILESDIR}"/server-CVE-2007-1003.patch
+ epatch "${FILESDIR}"/server-CVE-2007-1351-1352.patch
+ epatch "${FILESDIR}"/1.3.9-fbsd.patch
+ epatch "${FILESDIR}"/1.3.9-arm.patch
+ epatch "${FILESDIR}"/1.3.9-sh.patch
+
+ if use java; then
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}-1.3.10-java-build.patch"
+ fi
+}
+
+src_compile() {
+ xmkmf -a || die "xmkmf failed"
+
+ make CDEBUGFLAGS="${CFLAGS}" World || die
+
+ if use server; then
+ cd Xvnc && ./configure || die "Configure failed."
+ if use tcpd; then
+ local myextra="-lwrap"
+ make EXTRA_LIBRARIES="${myextra}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_DEFINES="-DUSE_LIBWRAP=1" || die
+ else
+ make CDEBUGFLAGS="${CFLAGS}" || die
+ fi
+ fi
+ if use java; then
+ cd "${WORKDIR}/vnc_javasrc" || die
+ make JAVACFLAGS="$(java-pkg_javac-args)" all || die
+ fi
+
+}
+
+src_install() {
+ # the web based interface and the java viewer need the java class files
+ if use java; then
+ java-pkg_newjar "${WORKDIR}/vnc_javasrc/VncViewer.jar"
+ java-pkg_dolauncher "${PN}-java"
+ insinto /usr/share/${PN}/classes
+ doins ${WORKDIR}/vnc_javasrc/*.vnc || die
+ dosym /usr/share/${PN}/lib/${PN}.jar /usr/share/${PN}/classes/VncViewer.jar
+
+ fi
+
+ dodir /usr/share/man/man1 /usr/bin
+ ./vncinstall "${D}"/usr/bin "${D}"/usr/share/man || die "vncinstall failed"
+
+ if use server; then
+ newconfd "${FILESDIR}"/tightvnc.confd vnc
+ newinitd "${FILESDIR}"/tightvnc.initd vnc
+ else
+ rm -f "${D}"/usr/bin/vncserver
+ rm -f "${D}"/usr/share/man/man1/{Xvnc,vncserver}*
+ fi
+
+ doicon "${FILESDIR}"/vncviewer.png
+ make_desktop_entry vncviewer vncviewer vncviewer Network
+
+ dodoc ChangeLog README WhatsNew
+ use java && dodoc "${FILESDIR}"/README.JavaViewer
+ newdoc vncviewer/README README.vncviewer
+}
diff --git a/net-misc/tightvnc/tightvnc-1.3.9-r3.ebuild b/net-misc/tightvnc/tightvnc-1.3.9-r3.ebuild
new file mode 100644
index 000000000000..478690cbe6f1
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.3.9-r3.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.3.9-r3.ebuild,v 1.1 2009/04/20 18:52:22 serkan Exp $
+
+inherit eutils toolchain-funcs java-pkg-opt-2
+
+IUSE="java tcpd server"
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2
+ java? ( mirror://sourceforge/vnc-tight/${P}_javasrc.tar.gz )"
+HOMEPAGE="http://www.tightvnc.com/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~sh ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+CDEPEND="~media-libs/jpeg-6b
+ server? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ x11-apps/rgb
+ x11-apps/xauth
+ x11-apps/xsetroot
+ )
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXt
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ x11-proto/xextproto
+ x11-proto/xproto
+ server? (
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/printproto
+ )
+ >=x11-misc/imake-1
+ x11-misc/gccmakedep
+ x11-misc/makedepend
+ !net-misc/vnc"
+
+src_unpack() {
+
+ if ! use server;
+ then
+ echo
+ einfo "The 'server' USE flag will build tightvnc's server."
+ einfo "If '-server' is chosen only the client is built to save space."
+ einfo "Stop the build now if you need to add 'server' to USE flags.\n"
+ ebeep
+ epause 5
+ fi
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.3.8-pathfixes.patch" # fixes bug 78385 and 146099
+ epatch "${FILESDIR}/${PN}-1.3.8-imake-tmpdir.patch" # fixes bug 23483
+ epatch "${FILESDIR}/${PN}-1.3.8-darwin.patch" # fixes bug 89908
+ epatch "${FILESDIR}/${PN}-1.3.8-mips.patch"
+ epatch "${FILESDIR}"/server-CVE-2007-1003.patch
+ epatch "${FILESDIR}"/server-CVE-2007-1351-1352.patch
+ epatch "${FILESDIR}"/${PV}-fbsd.patch
+ epatch "${FILESDIR}"/${PV}-arm.patch
+ epatch "${FILESDIR}"/${PV}-sh.patch
+
+ if use java; then
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${P}-java-build.patch"
+ fi
+}
+
+src_compile() {
+ xmkmf -a || die "xmkmf failed"
+
+ make CDEBUGFLAGS="${CFLAGS}" World || die
+
+ if use server; then
+ cd Xvnc && ./configure || die "Configure failed."
+ if use tcpd; then
+ local myextra="-lwrap"
+ make EXTRA_LIBRARIES="${myextra}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_DEFINES="-DUSE_LIBWRAP=1" || die
+ else
+ make CDEBUGFLAGS="${CFLAGS}" || die
+ fi
+ fi
+ if use java; then
+ cd "${WORKDIR}/vnc_javasrc" || die
+ make JAVACFLAGS="$(java-pkg_javac-args)" all || die
+ fi
+
+}
+
+src_install() {
+ # the web based interface and the java viewer need the java class files
+ if use java; then
+ java-pkg_newjar "${WORKDIR}/vnc_javasrc/VncViewer.jar"
+ java-pkg_dolauncher "${PN}-java"
+ insinto /usr/share/${PN}/classes
+ doins ${WORKDIR}/vnc_javasrc/*.vnc || die
+ dosym /usr/share/${PN}/lib/${PN}.jar /usr/share/${PN}/classes/VncViewer.jar
+
+ fi
+
+ dodir /usr/share/man/man1 /usr/bin
+ ./vncinstall "${D}"/usr/bin "${D}"/usr/share/man || die "vncinstall failed"
+
+ if use server; then
+ newconfd "${FILESDIR}"/tightvnc.confd vnc
+ newinitd "${FILESDIR}"/tightvnc.initd vnc
+ else
+ rm -f "${D}"/usr/bin/vncserver
+ rm -f "${D}"/usr/share/man/man1/{Xvnc,vncserver}*
+ fi
+
+ doicon "${FILESDIR}"/vncviewer.png
+ make_desktop_entry vncviewer vncviewer vncviewer Network
+
+ dodoc ChangeLog README WhatsNew
+ use java && dodoc "${FILESDIR}"/README.JavaViewer
+ newdoc vncviewer/README README.vncviewer
+}