summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-06-03 08:09:04 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-06-03 08:09:04 +0000
commit0bff9bee41c2055fd660f4a6cb95909409dbb7bf (patch)
tree8a9dedd49c488a2d61bcf80a0c44b06dec200c16 /net-misc/tor
parentRequest automake 1.9 otherwise eautomake fails. (diff)
downloadgentoo-2-0bff9bee41c2055fd660f4a6cb95909409dbb7bf.tar.gz
gentoo-2-0bff9bee41c2055fd660f4a6cb95909409dbb7bf.tar.bz2
gentoo-2-0bff9bee41c2055fd660f4a6cb95909409dbb7bf.zip
Really respect limits from /etc/limits.d/ by some tweaks: moving user context switch from torrc to init script, including verification of config file in the latter; fixes bug 268396 by W. Elschner <gentoobugzilla_reply AT elschner DOT net>
(Portage version: 2.1.6.11/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog12
-rw-r--r--net-misc/tor/files/tor.initd-r5 (renamed from net-misc/tor/files/tor.initd-r4)10
-rw-r--r--net-misc/tor/files/torrc.sample-0.1.2.6.patch6
-rw-r--r--net-misc/tor/tor-0.2.0.34-r1.ebuild (renamed from net-misc/tor/tor-0.2.0.34.ebuild)4
4 files changed, 19 insertions, 13 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 6b7a8c46e597..b96607057394 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-misc/tor
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.163 2009/02/19 18:58:37 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.164 2009/06/03 08:09:04 fauli Exp $
+
+*tor-0.2.0.34-r1 (03 Jun 2009)
+
+ 03 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
+ files/torrc.sample-0.1.2.6.patch, -files/tor.initd-r4,
+ +files/tor.initd-r5, -tor-0.2.0.34.ebuild, +tor-0.2.0.34-r1.ebuild:
+ Really respect limits from /etc/limits.d/ by some tweaks: moving user
+ context switch from torrc to init script, including verification of config
+ file in the latter; fixes bug 268396 by W. Elschner <gentoobugzilla_reply AT
+ elschner DOT net>
19 Feb 2009; nixnut <nixnut@gentoo.org> tor-0.2.0.34.ebuild:
ppc stable
diff --git a/net-misc/tor/files/tor.initd-r4 b/net-misc/tor/files/tor.initd-r5
index fb98a925debd..2d2926a9d00f 100644
--- a/net-misc/tor/files/tor.initd-r4
+++ b/net-misc/tor/files/tor.initd-r5
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/files/tor.initd-r4,v 1.2 2008/09/06 19:34:09 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/files/tor.initd-r5,v 1.1 2009/06/03 08:09:04 fauli Exp $
opts="${opts} checkconfig reload"
PIDFILE=/var/run/tor/tor.pid
@@ -20,13 +20,13 @@ checkconfig() {
fi
# now verify whether the configuration is valid
- /usr/bin/tor --verify-config -f ${CONFFILE} > /dev/null 2>&1
+ /usr/bin/tor --verify-config --User tor -f ${CONFFILE} > /dev/null 2>&1
if [ $? -eq 0 ] ; then
einfo "Tor configuration (${CONFFILE}) is valid."
return 0
else
eerror "Tor configuration (${CONFFILE}) not valid."
- /usr/bin/tor --verify-config -f ${CONFFILE}
+ /usr/bin/tor --verify-config --User tor -f ${CONFFILE}
return 1
fi
}
@@ -35,13 +35,13 @@ start() {
checkconfig || return 1
ebegin "Starting Tor"
HOME=/var/lib/tor
- start-stop-daemon --start --pidfile "${PIDFILE}" --quiet --exec /usr/bin/tor -- --runasdaemon 1 --PidFile "${PIDFILE}" > /dev/null 2>&1
+ start-stop-daemon --start --user tor:tor --pidfile "${PIDFILE}" --quiet --exec /usr/bin/tor -- --runasdaemon 1 --PidFile "${PIDFILE}" > /dev/null 2>&1
eend $?
}
stop() {
ebegin "Stopping Tor"
- start-stop-daemon --stop --pidfile "${PIDFILE}" --exec /usr/bin/tor -- --PidFile "${PIDFILE}"
+ start-stop-daemon --stop --user tor:tor --pidfile "${PIDFILE}" --exec /usr/bin/tor -- --PidFile "${PIDFILE}"
eend $?
}
diff --git a/net-misc/tor/files/torrc.sample-0.1.2.6.patch b/net-misc/tor/files/torrc.sample-0.1.2.6.patch
index 7317552c237f..99959f47a211 100644
--- a/net-misc/tor/files/torrc.sample-0.1.2.6.patch
+++ b/net-misc/tor/files/torrc.sample-0.1.2.6.patch
@@ -1,13 +1,9 @@
--- src/config/torrc.sample.in.orig 2007-01-27 23:41:23.000000000 +0000
+++ src/config/torrc.sample.in 2007-01-27 23:43:47.000000000 +0000
-@@ -18,6 +18,11 @@
+@@ -18,6 +18,7 @@
## With the default Mac OS X installer, Tor will look in ~/.tor/torrc or
## /Library/Tor/torrc
-+## Default username and group the server will run as
-+User tor
-+Group tor
-+
+PIDFile /var/run/tor/tor.pid
## Replace this with "SocksPort 0" if you plan to run Tor only as a
diff --git a/net-misc/tor/tor-0.2.0.34.ebuild b/net-misc/tor/tor-0.2.0.34-r1.ebuild
index 5954622a57b9..7d1f17959c25 100644
--- a/net-misc/tor/tor-0.2.0.34.ebuild
+++ b/net-misc/tor/tor-0.2.0.34-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.0.34.ebuild,v 1.5 2009/02/19 18:58:37 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.0.34-r1.ebuild,v 1.1 2009/06/03 08:09:04 fauli Exp $
EAPI=1
@@ -49,7 +49,7 @@ src_compile() {
}
src_install() {
- newinitd "${FILESDIR}"/tor.initd-r4 tor
+ newinitd "${FILESDIR}"/tor.initd-r5 tor
emake DESTDIR="${D}" install || die
keepdir /var/{lib,log,run}/tor