summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2005-01-07 18:45:12 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2005-01-07 18:45:12 +0000
commit45b1e8893e4919b85cf33f05751790ab5f10dbb8 (patch)
treeb0bbcef90ae6cb69d90f0878cfd4ead8a4d930ef /net-misc/vnc
parentnew version released. fixes bug #77035. (Manifest recommit) (diff)
downloadgentoo-2-45b1e8893e4919b85cf33f05751790ab5f10dbb8.tar.gz
gentoo-2-45b1e8893e4919b85cf33f05751790ab5f10dbb8.tar.bz2
gentoo-2-45b1e8893e4919b85cf33f05751790ab5f10dbb8.zip
Closing #68290.
Diffstat (limited to 'net-misc/vnc')
-rw-r--r--net-misc/vnc/ChangeLog3
-rw-r--r--net-misc/vnc/vnc-4.0-r1.ebuild18
2 files changed, 14 insertions, 7 deletions
diff --git a/net-misc/vnc/ChangeLog b/net-misc/vnc/ChangeLog
index fddba6d92c32..d67ff40ff534 100644
--- a/net-misc/vnc/ChangeLog
+++ b/net-misc/vnc/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for net-misc/vnc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.30 2005/01/07 18:12:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.31 2005/01/07 18:45:12 aliz Exp $
*vnc-4.0-r1 (07 Jan 2005)
@@ -11,6 +11,7 @@
Create /usr/X11R6/lib/modules/extensions so that .so file gets installed, closing #63596.
Added patch to prevent /tmp execution, closing #71295.
Don't hardcode CC/CXX, closing #69277.
+ Split server and client with USE flags, closing #68290."
Updated SRC_URI to xorg.freedesktop.org.
15 Sep 2004; <agriffis@gentoo.org> vnc-4.0.ebuild:
diff --git a/net-misc/vnc/vnc-4.0-r1.ebuild b/net-misc/vnc/vnc-4.0-r1.ebuild
index 05d711c19d9e..e3efbf155c35 100644
--- a/net-misc/vnc/vnc-4.0-r1.ebuild
+++ b/net-misc/vnc/vnc-4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-4.0-r1.ebuild,v 1.1 2005/01/07 18:12:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-4.0-r1.ebuild,v 1.2 2005/01/07 18:45:12 aliz Exp $
inherit eutils toolchain-funcs
@@ -17,7 +17,7 @@ SRC_URI="http://www.realvnc.com/dist/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc ~amd64"
-IUSE=""
+IUSE="client server"
DEPEND="sys-libs/zlib
media-libs/freetype
@@ -27,6 +27,12 @@ DEPEND="sys-libs/zlib
PROVIDE="virtual/vnc"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if ! use client && ! use server ; then
+ die "You must have either client or server or both in USE"
+ fi
+}
+
src_unpack() {
mkdir -p ${S}/xc ; cd ${S}
@@ -58,13 +64,13 @@ src_unpack() {
}
src_compile() {
- # client
+ use client && (
econf --with-installed-zlib || die
- emake || die
+ emake || die )
- # server
+ use server && (
cd ${S}/xc
- make CDEBUGFLAGS="${CFLAGS}" CXXDEBUGFLAGS="${CXXFLAGS}" World FAST=1 || die
+ make CDEBUGFLAGS="${CFLAGS}" CXXDEBUGFLAGS="${CXXFLAGS}" World FAST=1 || die )
}
src_install() {