summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-03-14 22:27:01 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-03-14 22:27:01 +0000
commitfcfc3ff9966794858e1be6f9df324000525571c4 (patch)
treed47faa98a5f99ccdcaaccc5f36e52182736259cb /net-misc/x2goclient
parentRemove xulrunner dependency, bug #407565. (diff)
downloadgentoo-2-fcfc3ff9966794858e1be6f9df324000525571c4.tar.gz
gentoo-2-fcfc3ff9966794858e1be6f9df324000525571c4.tar.bz2
gentoo-2-fcfc3ff9966794858e1be6f9df324000525571c4.zip
Version bump, new homepage and source, clean ebuild, new versioning. Bug #408105
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/x2goclient')
-rw-r--r--net-misc/x2goclient/ChangeLog12
-rw-r--r--net-misc/x2goclient/files/x2goclient-3.01.5-noldap.patch26
-rw-r--r--net-misc/x2goclient/x2goclient-3.0.1.18.ebuild45
-rw-r--r--net-misc/x2goclient/x2goclient-3.01.5.ebuild52
4 files changed, 55 insertions, 80 deletions
diff --git a/net-misc/x2goclient/ChangeLog b/net-misc/x2goclient/ChangeLog
index cd8634da3720..42df08e45b99 100644
--- a/net-misc/x2goclient/ChangeLog
+++ b/net-misc/x2goclient/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/x2goclient
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.6 2011/08/19 09:55:55 voyageur Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.7 2012/03/14 22:27:01 voyageur Exp $
+
+*x2goclient-3.0.1.18 (14 Mar 2012)
+
+ 14 Mar 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ +x2goclient-3.0.1.18.ebuild, -x2goclient-3.01.5.ebuild,
+ -files/x2goclient-3.01.5-noldap.patch:
+ Version bump, new homepage and source, clean ebuild, new versioning. Bug
+ #408105
19 Aug 2011; Bernard Cafarelli <voyageur@gentoo.org>
x2goclient-3.01.5.ebuild:
diff --git a/net-misc/x2goclient/files/x2goclient-3.01.5-noldap.patch b/net-misc/x2goclient/files/x2goclient-3.01.5-noldap.patch
deleted file mode 100644
index ccb27e6ae728..000000000000
--- a/net-misc/x2goclient/files/x2goclient-3.01.5-noldap.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -Naur x2goclient-3.01.orig/x2goclientconfig.h x2goclient-3.01/x2goclientconfig.h
---- x2goclient-3.01.orig/x2goclientconfig.h 2010-04-19 20:19:56.000000000 +0200
-+++ x2goclient-3.01/x2goclientconfig.h 2010-04-19 20:21:05.000000000 +0200
-@@ -8,10 +8,6 @@
-
- //#define LOGFILE QDir::homePath()+"/x2goclient.log"
-
--#if !defined Q_OS_WIN
--#define USELDAP
--#endif
--
- #ifdef Q_OS_WIN
- #undef USELDAP
- #endif
-diff -Naur x2goclient-3.01.orig/x2goclient.pro x2goclient-3.01/x2goclient.pro
---- x2goclient-3.01.orig/x2goclient.pro 2010-04-19 20:19:57.000000000 +0200
-+++ x2goclient-3.01/x2goclient.pro 2010-04-19 20:21:30.000000000 +0200
-@@ -70,7 +70,7 @@
-
- linux-g++ {
- message(building x2goclient with ldap and cups)
-- LIBS += -lldap -lcups
-+ LIBS += -lcups
- }
- macx {
- message(building x2goclient with ldap and cups)
diff --git a/net-misc/x2goclient/x2goclient-3.0.1.18.ebuild b/net-misc/x2goclient/x2goclient-3.0.1.18.ebuild
new file mode 100644
index 000000000000..9a22de2b16e5
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-3.0.1.18.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-3.0.1.18.ebuild,v 1.1 2012/03/14 22:27:01 voyageur Exp $
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND="net-libs/libssh
+ net-print/cups
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+S=${WORKDIR}/${P/-/_}
+
+src_prepare() {
+ # qmake looks for these files in the main directory
+ mv x2goclient/* . && rmdir x2goclient || die
+ sed -e "s#cups/cups.h#cups/ppd.h#" -i cupsprint.h || die
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ make_desktop_entry ${PN} "X2go client" ${PN} "Network"
+}
diff --git a/net-misc/x2goclient/x2goclient-3.01.5.ebuild b/net-misc/x2goclient/x2goclient-3.01.5.ebuild
deleted file mode 100644
index 277c88d985c1..000000000000
--- a/net-misc/x2goclient/x2goclient-3.01.5.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-3.01.5.ebuild,v 1.2 2011/08/19 09:55:55 voyageur Exp $
-
-EAPI="3"
-inherit qt4-r2 versionator
-
-MAJOR_PV="$(get_version_component_range 1-2)"
-FULL_PV="${MAJOR_PV}-$(get_version_component_range 3)"
-DESCRIPTION="The X2Go Qt client"
-HOMEPAGE="http://x2go.berlios.de"
-SRC_URI="http://x2go.obviously-nice.de/deb/pool-lenny/${PN}/${PN}_${FULL_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cups ldap"
-
-DEPEND="net-misc/nx
- net-print/cups
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- x11-libs/qt-svg:4
- ldap? ( net-nds/openldap )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}-${MAJOR_PV}
-
-src_prepare() {
- use ldap || epatch "${FILESDIR}"/${P}-noldap.patch
-}
-
-src_install() {
- dobin ${PN}
- dodoc README
-
- # copying the icons
- insinto /usr/share/pixmaps/x2goclient
- doins icons/*
- insinto /usr/share/pixmaps/x2goclient/16x16
- doins icons/16x16/*
- insinto /usr/share/pixmaps/x2goclient/32x32
- doins icons/32x32/*
- insinto /usr/share/pixmaps/x2goclient/64x64
- doins icons/64x64/*
- insinto /usr/share/pixmaps/x2goclient/128x128
- doins icons/128x128/*
- insinto /usr/share/pixmaps/x2goclient/hildon
- doins icons/hildon/*
-
- make_desktop_entry ${PN} "X2go client" ${PN} "Network"
-}