summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-02-09 22:01:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-02-09 22:01:45 +0000
commitc5a043bcaf4589dbf300639ca8530e3112cddf11 (patch)
tree73f4666ff5843ef02c2ab1fcd34db3e46333a63f /net-misc/zsync/zsync-0.6.2.ebuild
parentRevert removing USE="jpeg jpeg2k tiff" until gentoo-x86 is compatible with it... (diff)
downloadgentoo-2-c5a043bcaf4589dbf300639ca8530e3112cddf11.tar.gz
gentoo-2-c5a043bcaf4589dbf300639ca8530e3112cddf11.tar.bz2
gentoo-2-c5a043bcaf4589dbf300639ca8530e3112cddf11.zip
Re-add zsync with a port of zlib-1.2.3 for previous security problem.
(Portage version: 2.2.0_alpha21/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/zsync/zsync-0.6.2.ebuild')
-rw-r--r--net-misc/zsync/zsync-0.6.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/zsync/zsync-0.6.2.ebuild b/net-misc/zsync/zsync-0.6.2.ebuild
new file mode 100644
index 000000000000..e7e89368c3bb
--- /dev/null
+++ b/net-misc/zsync/zsync-0.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zsync/zsync-0.6.2.ebuild,v 1.1 2011/02/09 22:01:44 robbat2 Exp $
+
+EAPI=3
+inherit autotools eutils
+
+DESCRIPTION="Partial/differential file download client over HTTP which uses the rsync algorithm"
+HOMEPAGE="http://zsync.moria.org.uk/"
+
+ZLIB_PV=1.2.3
+ZLIB_P="zlib-${ZLIB_PV}"
+SRC_URI="http://zsync.moria.org.uk/download/${P}.tar.bz2
+ http://www.gzip.org/zlib/${ZLIB_P}.tar.bz2
+ http://www.zlib.net/${ZLIB_P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ZLIB_S="${WORKDIR}/${ZLIB_P}"
+
+src_prepare() {
+ # Move old zlib-1.2.11 out the way
+ cd "${S}"
+ mv "${S}"/zlib zlib-1.2.11-modified
+
+ cd "${ZLIB_S}"
+ # I am not sure how many other zlib patches we will need to port as well
+ # This covers the security vuln in 1.2.11
+ epatch "${FILESDIR}"/${P}-${ZLIB_P}-support.patch
+ rm -f Makefile
+
+ cd "${S}"
+ cp -a "${ZLIB_S}" "${ZLIB_P}-modified"
+ ln -s "${ZLIB_P}-modified" zlib
+
+ eautoreconf
+}
+
+src_install() {
+ dobin zsync zsyncmake
+ dodoc NEWS README
+ doman doc/zsync.1 doc/zsyncmake.1
+}
+