summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2004-03-17 04:22:09 +0000
committerDylan Carlson <absinthe@gentoo.org>2004-03-17 04:22:09 +0000
commit20ef33288c5dd645a371e6f3cb40148ea309ff19 (patch)
tree781496e79a74307a5e070a8657c65266e2ebc302 /net-misc
parentAdded accessibility to metadata.xml (diff)
downloadgentoo-2-20ef33288c5dd645a371e6f3cb40148ea309ff19.tar.gz
gentoo-2-20ef33288c5dd645a371e6f3cb40148ea309ff19.tar.bz2
gentoo-2-20ef33288c5dd645a371e6f3cb40148ea309ff19.zip
Version bumpage. Added ~amd64 to KEYWORDS.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ices/ChangeLog9
-rw-r--r--net-misc/ices/Manifest9
-rw-r--r--net-misc/ices/files/digest-ices-2.0.01
-rw-r--r--net-misc/ices/ices-2.0.0.ebuild57
4 files changed, 71 insertions, 5 deletions
diff --git a/net-misc/ices/ChangeLog b/net-misc/ices/ChangeLog
index fd93c3cb0765..7ccf3133251d 100644
--- a/net-misc/ices/ChangeLog
+++ b/net-misc/ices/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ices
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ChangeLog,v 1.6 2004/01/21 06:32:07 raker Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ChangeLog,v 1.7 2004/03/17 04:22:09 absinthe Exp $
+
+*ices-2.0.0 (16 Mar 2004)
+
+ 16 Mar 2004; Dylan Carlson <absinthe@gentoo.org> ices-2.0.0.ebuild:
+ Version bump. Added ~amd64 to KEYWORDS.
*ices-2.0_beta4 (21 Jan 2004)
diff --git a/net-misc/ices/Manifest b/net-misc/ices/Manifest
index 59dd6e5aba57..c70b9d975fea 100644
--- a/net-misc/ices/Manifest
+++ b/net-misc/ices/Manifest
@@ -1,9 +1,12 @@
+MD5 04831103a1e6d0cc6c21e57629ae1cd0 ChangeLog 1065
MD5 3f5505aa43962648812bfc7dfe5d8dfb ices-0.2.3.ebuild 1067
MD5 a22a95d1927da153b21f0588d0e8167e ices-0.3.ebuild 1107
MD5 4580606e800b636a1a0454968093ff77 ices-2.0_beta4.ebuild 1475
-MD5 04831103a1e6d0cc6c21e57629ae1cd0 ChangeLog 1065
MD5 05ab4d4775083f0930841e415df18ad6 metadata.xml 160
-MD5 7b90256f350052b7ec4122e85edd0758 files/docdir.diff 3909
-MD5 d966b9c189c4f85caca6ec95e1f9b96d files/digest-ices-0.3 60
+MD5 dc0018241435baf32f788dddd2324116 ices-2.0.0.ebuild 1461
MD5 9efe5e3855ca15b4185a712b51c81291 files/digest-ices-0.2.3 62
+MD5 d966b9c189c4f85caca6ec95e1f9b96d files/digest-ices-0.3 60
MD5 ad65ac61ebb4b16e6286bf457a03111e files/digest-ices-2.0_beta4 66
+MD5 7b90256f350052b7ec4122e85edd0758 files/docdir.diff 3909
+MD5 ad65ac61ebb4b16e6286bf457a03111e files/digest-ices-2.0 66
+MD5 ace2a441b6354b065c6be58e9056ec82 files/digest-ices-2.0.0 62
diff --git a/net-misc/ices/files/digest-ices-2.0.0 b/net-misc/ices/files/digest-ices-2.0.0
new file mode 100644
index 000000000000..3c7e7d50d1b3
--- /dev/null
+++ b/net-misc/ices/files/digest-ices-2.0.0
@@ -0,0 +1 @@
+MD5 da09d6ee04cbd228c49f2eea63180d65 ices-2.0.0.tar.gz 408155
diff --git a/net-misc/ices/ices-2.0.0.ebuild b/net-misc/ices/ices-2.0.0.ebuild
new file mode 100644
index 000000000000..75e5116ffbaa
--- /dev/null
+++ b/net-misc/ices/ices-2.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ices-2.0.0.ebuild,v 1.1 2004/03/17 04:22:09 absinthe Exp $
+
+IUSE="oggvorbis"
+
+DESCRIPTION="icecast MP3 streaming client. supports on the fly re-encoding"
+SRC_URI="http://www.icecast.org/files/${P}.tar.gz"
+HOMEPAGE="http://www.icecast.org/ices.php"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64"
+
+DEPEND="dev-libs/libxml2
+ dev-util/pkgconfig
+ >=media-libs/libshout-2.0
+ oggvorbis? ( >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )"
+
+S=${WORKDIR}/${P}
+
+src_compile ()
+{
+ local myconf=""
+
+ use oggvorbis || \
+ myconf="${myconf} --with-vorbis=no --with-ogg=no"
+
+ econf \
+ --sysconfdir=/etc/ices2 \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install ()
+{
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS README TODO
+
+ # Add the stock configs...
+ dodir /etc/ices2
+ mv ${D}usr/share/ices/ices-live.xml \
+ ${D}etc/ices2/ices-live.xml.dist
+ mv ${D}usr/share/ices/ices-playlist.xml \
+ ${D}etc/ices2/ices-playlist.xml.dist
+
+ # Move the html to it's proper location...
+ dodir /usr/share/doc/${PN}-2.0_beta4/html
+ mv ${D}usr/share/ices/*.html ${D}usr/share/doc/${PN}-2.0_beta4/html
+ mv ${D}usr/share/ices/style.css ${D}usr/share/doc/${PN}-2.0_beta4/html
+
+ # Nothing is left here after things are moved...
+ rmdir ${D}usr/share/ices
+}