summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-08-05 02:46:45 +0000
committerAron Griffis <agriffis@gentoo.org>2002-08-05 02:46:45 +0000
commit326ac05842ccaed0573f8d15d1b678275d94c465 (patch)
tree9470136493b732bedc64494e316e3dfa0e497741 /net-misc
parentAdded a patch to fix broken nls translations. Added a test for nls. This fixe... (diff)
downloadgentoo-2-326ac05842ccaed0573f8d15d1b678275d94c465.tar.gz
gentoo-2-326ac05842ccaed0573f8d15d1b678275d94c465.tar.bz2
gentoo-2-326ac05842ccaed0573f8d15d1b678275d94c465.zip
Added ebuild for rdist
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rdist/files/digest-rdist-6.1.51
-rw-r--r--net-misc/rdist/rdist-6.1.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/rdist/files/digest-rdist-6.1.5 b/net-misc/rdist/files/digest-rdist-6.1.5
new file mode 100644
index 000000000000..ad463b9ef498
--- /dev/null
+++ b/net-misc/rdist/files/digest-rdist-6.1.5
@@ -0,0 +1 @@
+MD5 546779700af70aa5f9103e08782cdcac rdist-6.1.5.tar.gz 117861
diff --git a/net-misc/rdist/rdist-6.1.5.ebuild b/net-misc/rdist/rdist-6.1.5.ebuild
new file mode 100644
index 000000000000..b72f94ae0a9f
--- /dev/null
+++ b/net-misc/rdist/rdist-6.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdist/rdist-6.1.5.ebuild,v 1.1 2002/08/05 02:46:45 agriffis Exp $
+
+DESCRIPTION="Remote software distribution system"
+HOMEPAGE="http://www.magnicomp.com/rdist/rdist.shtml"
+SRC_URI="http://www.magnicomp.com/download/rdist/${P}.tar.gz"
+LICENSE="RDist"
+SLOT="1"
+KEYWORDS="x86"
+DEPEND="dev-util/yacc"
+RDEPEND="" # yacc only needed for compile
+S=${WORKDIR}/${P}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install () {
+ mkdir -p ${D}/usr/bin ${D}/usr/share/man/man{1,8}
+ make install BIN_DIR=${D}/usr/bin || die "make install failed"
+ make install.man \
+ MAN_1_DIR=${D}/usr/share/man/man1 MAN_8_DIR=${D}/usr/share/man/man8 \
+ || die "make install.man failed"
+}