summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
commit3b400917584ce927f27df4cf507cc5630759f143 (patch)
treec5148d0abb45f9c45a2fd8ad233dcda899e8da92 /net-misc
parent*** empty log message *** (diff)
downloadgentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.gz
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.bz2
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.zip
*** empty log message ***
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nut/files/digest-nut-0.44.11
-rw-r--r--net-misc/nut/nut-0.44.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/nut/files/digest-nut-0.44.1 b/net-misc/nut/files/digest-nut-0.44.1
new file mode 100644
index 000000000000..23b408a4f820
--- /dev/null
+++ b/net-misc/nut/files/digest-nut-0.44.1
@@ -0,0 +1 @@
+MD5 f34b5c9c4fd55b9763bd801bf88f4ed5 nut-0.44.1.tar.gz
diff --git a/net-misc/nut/nut-0.44.1.ebuild b/net-misc/nut/nut-0.44.1.ebuild
new file mode 100644
index 000000000000..1c0467dc3343
--- /dev/null
+++ b/net-misc/nut/nut-0.44.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/nut-0.44.1.ebuild,v 1.1 2000/08/25 15:10:24 achim Exp $
+
+P=nut-0.44.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Network-UPS Tools"
+SRC_URI="http://www.exploits.org/nut/release/"${A}
+HOMEPAGE="http://www.exploits.org/nut/"
+
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/nut \
+ --with-user=daemon --with-group=daemon
+ make
+ make cgi
+}
+
+src_install() {
+ cd ${S}
+ make BASEPATH=${D}/usr CONFPATH=${D}/etc/nut STATEPATH=${D}/var/state/ups \
+ install
+ cd clients
+ exeinto /usr/local/httpd/cgi-bin/nut
+ doexe *.cgi
+ into /usr
+ dolib upsfetch.o
+ insinto /usr/include
+ doins upsfetch.h
+ cd ..
+ rmdir ${D}/usr/misc
+ insinto /etc/rc.d/init.d
+ doins ${O}/files/upsd
+ dodoc COPYING CREDITS Changes QUICKSTART README
+ docinto docs
+ dodoc docs/*.txt docs/FAQ docs/Changes.trust
+ docinto cables
+ dodoc docs/cables/*.txt
+}
+
+
+pkg_config() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ einfo "Generating symlinks..."
+ ${ROOT}/usr/sbin/rc-update add upsd
+
+}
+
+