summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-30 12:42:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-30 12:42:20 +0000
commit5f3983e772a7642e113f7316e1532fc2fae7cfcf (patch)
treefd99852a458eb354fdfae72c7abfac51cfbec9dc /net-misc
parentCleanup (diff)
downloadgentoo-2-5f3983e772a7642e113f7316e1532fc2fae7cfcf.tar.gz
gentoo-2-5f3983e772a7642e113f7316e1532fc2fae7cfcf.tar.bz2
gentoo-2-5f3983e772a7642e113f7316e1532fc2fae7cfcf.zip
Added USE build,static,nls
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/files/digest-wget-1.5.3-r2 (renamed from net-misc/wget/files/digest-wget-1.5.3-r1)0
-rw-r--r--net-misc/wget/wget-1.5.3-r2.ebuild (renamed from net-misc/wget/wget-1.5.3-r1.ebuild)33
2 files changed, 24 insertions, 9 deletions
diff --git a/net-misc/wget/files/digest-wget-1.5.3-r1 b/net-misc/wget/files/digest-wget-1.5.3-r2
index 3e03558f217b..3e03558f217b 100644
--- a/net-misc/wget/files/digest-wget-1.5.3-r1
+++ b/net-misc/wget/files/digest-wget-1.5.3-r2
diff --git a/net-misc/wget/wget-1.5.3-r1.ebuild b/net-misc/wget/wget-1.5.3-r2.ebuild
index 1632432a6c5b..44e74c57f923 100644
--- a/net-misc/wget/wget-1.5.3-r1.ebuild
+++ b/net-misc/wget/wget-1.5.3-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.5.3-r1.ebuild,v 1.6 2001/03/06 05:27:28 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.5.3-r2.ebuild,v 1.1 2001/04/30 12:42:20 achim Exp $
A="${P}.tar.gz wget-new-percentage-3.0.tgz"
S=${WORKDIR}/${P}
@@ -11,7 +11,8 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
http://www.biscom.net/~cade/away/projects/wget-new-percentage-3.0.tgz"
HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
-DEPEND=">=sys-libs/glibc-2.1.3"
+DEPEND=">=sys-libs/glibc-2.1.3
+ nls? ( sys-devel/gettext )"
src_unpack () {
unpack ${A}
@@ -20,17 +21,31 @@ src_unpack () {
patch retr.c < ../../wget-new-percentage/wget-new-percentage.diff
}
src_compile() {
-
- try ./configure --prefix=/usr --sysconfdir=/etc/wget --infodir=/usr/share/info --disable-debug
- try make
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ -z "$DEBUG" ] ; then
+ myconf="$myconf --disable-debug"
+ fi
+ try ./configure --prefix=/usr --sysconfdir=/etc/wget --infodir=/usr/share/info $myconf
+ if [ "`use static`" ] ; then
+ try make -e LDFLAGS=\"--static\"
+ else
+ try make
+ fi
}
src_install() {
-
- try make prefix=${D}/usr sysconfdir=${D}/etc/wget infodir=${D}/usr/share/info install
+
+ if [ "`use build`" ] ; then
+ dobin wget
+ else
+ try make prefix=${D}/usr sysconfdir=${D}/etc/wget infodir=${D}/usr/share/info install
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+ fi
}