summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-05-27 12:48:09 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-05-27 12:48:09 +0000
commit6337c642ba06d5836f983fd121d0b5320cdc989b (patch)
tree8e33f4fb50ae97a2cabdcf11b39c2607d6dcce44 /net-misc
parentarm stable wrt bug #545194 (diff)
downloadgentoo-2-6337c642ba06d5836f983fd121d0b5320cdc989b.tar.gz
gentoo-2-6337c642ba06d5836f983fd121d0b5320cdc989b.tar.bz2
gentoo-2-6337c642ba06d5836f983fd121d0b5320cdc989b.zip
Version bump, only install icon for desktop file (and not all resources)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/x2goclient/ChangeLog8
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.4.0.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/net-misc/x2goclient/ChangeLog b/net-misc/x2goclient/ChangeLog
index 4fb136762c4b..41fec200204f 100644
--- a/net-misc/x2goclient/ChangeLog
+++ b/net-misc/x2goclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/x2goclient
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.40 2015/04/19 09:58:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.41 2015/05/27 12:48:09 voyageur Exp $
+
+*x2goclient-4.0.4.0 (27 May 2015)
+
+ 27 May 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +x2goclient-4.0.4.0.ebuild:
+ Version bump, only install icon for desktop file (and not all resources)
19 Apr 2015; Agostino Sarubbo <ago@gentoo.org> x2goclient-4.0.3.2.ebuild:
Stable for x86, wrt bug #546624
diff --git a/net-misc/x2goclient/x2goclient-4.0.4.0.ebuild b/net-misc/x2goclient/x2goclient-4.0.4.0.ebuild
new file mode 100644
index 000000000000..33a61abd9106
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.4.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.4.0.ebuild,v 1.1 2015/05/27 12:48:09 voyageur Exp $
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i src/x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins res/img/icons/${PN}.xpm
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}