summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 16:34:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 16:34:01 +0000
commit7f572daa33eda2f0a2180c5a432e47189c4e83d9 (patch)
tree6fbe7237e596a03433ed43d568fc9f6496548ef5 /net-misc
parentx86 stable wrt bug #353264 (diff)
downloadgentoo-2-7f572daa33eda2f0a2180c5a432e47189c4e83d9.tar.gz
gentoo-2-7f572daa33eda2f0a2180c5a432e47189c4e83d9.tar.bz2
gentoo-2-7f572daa33eda2f0a2180c5a432e47189c4e83d9.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd-ui/ChangeLog8
-rw-r--r--net-misc/dhcpcd-ui/dhcpcd-ui-0.5.1.ebuild9
-rw-r--r--net-misc/dhcpcd-ui/files/dhcpcd-ui-0.5.1-libnotify-0.7.patch28
3 files changed, 41 insertions, 4 deletions
diff --git a/net-misc/dhcpcd-ui/ChangeLog b/net-misc/dhcpcd-ui/ChangeLog
index e13c95e89bf0..a82b165ce783 100644
--- a/net-misc/dhcpcd-ui/ChangeLog
+++ b/net-misc/dhcpcd-ui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/dhcpcd-ui
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd-ui/ChangeLog,v 1.3 2010/12/12 02:27:39 darkside Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd-ui/ChangeLog,v 1.4 2011/02/05 16:34:01 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> dhcpcd-ui-0.5.1.ebuild,
+ +files/dhcpcd-ui-0.5.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
*dhcpcd-ui-0.5.1 (12 Dec 2010)
diff --git a/net-misc/dhcpcd-ui/dhcpcd-ui-0.5.1.ebuild b/net-misc/dhcpcd-ui/dhcpcd-ui-0.5.1.ebuild
index 0a3726cd10a3..c11bc802e617 100644
--- a/net-misc/dhcpcd-ui/dhcpcd-ui-0.5.1.ebuild
+++ b/net-misc/dhcpcd-ui/dhcpcd-ui-0.5.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd-ui/dhcpcd-ui-0.5.1.ebuild,v 1.1 2010/12/12 02:27:39 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd-ui/dhcpcd-ui-0.5.1.ebuild,v 1.2 2011/02/05 16:34:01 ssuominen Exp $
EAPI=3
+inherit eutils
DESCRIPTION="Desktop notification and configuration for dhcpcd"
HOMEPAGE="http://roy.marples.name/projects/dhcpcd-ui/"
@@ -17,6 +18,10 @@ DEPEND="net-libs/dhcpcd-dbus
>=x11-libs/libnotify-0.4.4
x11-libs/gtk+:2"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die
}
diff --git a/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.5.1-libnotify-0.7.patch b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.5.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..e7d1fc4ffa52
--- /dev/null
+++ b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.5.1-libnotify-0.7.patch
@@ -0,0 +1,28 @@
+--- src/dhcpcd-gtk/main.c
++++ src/dhcpcd-gtk/main.c
+@@ -31,6 +31,9 @@
+
+ #ifdef NOTIFY
+ # include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ static NotifyNotification *nn;
+ #endif
+
+@@ -194,11 +197,15 @@
+ g_strfreev(msgs);
+ if (nn != NULL)
+ notify_notification_close(nn, NULL);
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ nn = notify_notification_new(title, msg, icon);
++#else
+ if (gtk_status_icon_get_visible(status_icon))
+ nn = notify_notification_new_with_status_icon(title,
+ msg, icon, status_icon);
+ else
+ nn = notify_notification_new(title, msg, icon, NULL);
++#endif
+ notify_notification_set_timeout(nn, 5000);
+ g_signal_connect(nn, "closed", G_CALLBACK(notify_closed), NULL);
+ notify_notification_show(nn, NULL);