summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-17 04:29:44 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-17 04:29:44 +0000
commit89ba4d320d8115f9f93221467b42edb57d802281 (patch)
treed5fe1e525a44d012067c15e0c7f5f354acfc2c68 /net-misc
parentUse `find` to clean up .la file #409261 by Kevin Pyle. (diff)
downloadgentoo-2-89ba4d320d8115f9f93221467b42edb57d802281.tar.gz
gentoo-2-89ba4d320d8115f9f93221467b42edb57d802281.tar.bz2
gentoo-2-89ba4d320d8115f9f93221467b42edb57d802281.zip
Add fix for POSIX test compat #391011.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog6
-rw-r--r--net-misc/openssh/files/openssh-6.0_p1-test.patch19
-rw-r--r--net-misc/openssh/openssh-6.0_p1.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 518bc3eb6592..9f0905c2f9ce 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.444 2012/05/08 15:39:19 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.445 2012/05/17 04:29:44 vapier Exp $
+
+ 17 May 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/openssh-6.0_p1-test.patch, openssh-6.0_p1.ebuild:
+ Add fix for POSIX test compat #391011.
08 May 2012; Brent Baude <ranger@gentoo.org> openssh-5.9_p1-r4.ebuild:
Marking openssh-5.9_p1-r4 ppc64 for bug 396075
diff --git a/net-misc/openssh/files/openssh-6.0_p1-test.patch b/net-misc/openssh/files/openssh-6.0_p1-test.patch
new file mode 100644
index 000000000000..8b988aed9b5e
--- /dev/null
+++ b/net-misc/openssh/files/openssh-6.0_p1-test.patch
@@ -0,0 +1,19 @@
+changeset: 10701:b159befd3104
+tag: tip
+user: Mike Frysinger <vapier@gentoo.org>
+date: Sun Apr 29 00:26:33 2012 -0400
+summary: use = with `test`, not ==
+
+diff -r d8a3ea854288 -r b159befd3104 configure.ac
+--- a/configure.ac Fri Apr 27 00:55:42 2012 +0000
++++ b/configure.ac Sun Apr 29 00:26:33 2012 -0400
+@@ -2591,7 +2591,7 @@
+ AC_DEFINE([SANDBOX_DARWIN], [1], [Sandbox using Darwin sandbox_init(3)])
+ elif test "x$sandbox_arg" = "xseccomp_filter" || \
+ ( test -z "$sandbox_arg" && \
+- test "x$have_seccomp_filter" == "x1" && \
++ test "x$have_seccomp_filter" = "x1" && \
+ test "x$ac_cv_header_linux_audit_h" = "xyes" && \
+ test "x$have_seccomp_audit_arch" = "x1" && \
+ test "x$have_linux_no_new_privs" = "x1" && \
+
diff --git a/net-misc/openssh/openssh-6.0_p1.ebuild b/net-misc/openssh/openssh-6.0_p1.ebuild
index 78ac2cbf1374..09f9ce1b92bf 100644
--- a/net-misc/openssh/openssh-6.0_p1.ebuild
+++ b/net-misc/openssh/openssh-6.0_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.0_p1.ebuild,v 1.3 2012/05/05 03:20:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.0_p1.ebuild,v 1.4 2012/05/17 04:29:44 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam systemd
@@ -99,6 +99,7 @@ src_prepare() {
else
use ldap && ewarn "Sorry, X509 and LDAP conflict internally, disabling LDAP"
fi
+ epatch "${FILESDIR}"/${PN}-6.0_p1-test.patch #391011
epatch "${FILESDIR}"/${PN}-4.7_p1-GSSAPI-dns.patch #165444 integrated into gsskex
if [[ -n ${HPN_PATCH} ]] && use hpn; then
epatch "${WORKDIR}"/${HPN_PATCH%.*}